Bug 1127770 - allinone - Failed to execute stage: pki-pkcs12-extract.sh
Summary: allinone - Failed to execute stage: pki-pkcs12-extract.sh
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1097188 1113974
TreeView+ depends on / blocked
 
Reported: 2014-08-07 14:11 UTC by Pavel Stehlik
Modified: 2014-08-12 15:02 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 11:28:38 UTC
oVirt Team: ---


Attachments (Terms of Use)
eng-allinone.tgz (247.71 KB, application/x-gzip)
2014-08-07 14:11 UTC, Pavel Stehlik
no flags Details

Description Pavel Stehlik 2014-08-07 14:11:56 UTC
Created attachment 924930 [details]
eng-allinone.tgz

Description of problem:
Allinone plugin failed during engine installation:
...
[ INFO  ] Creating/refreshing Engine database schema
[ INFO  ] Creating CA
[ ERROR ] Failed to execute stage 'Misc configuration': Command '/usr/share/ovirt-engine/bin/pki-pkcs12-extract.sh' failed to execute
[ INFO  ] Yum Performing yum transaction rollback
...

Version-Release number of selected component (if applicable):
3.5 rc1

How reproducible:


Steps to Reproduce:
1. yum install ovirt-engine-setup-plugin-allinone
2. engine-setup
3. 

Actual results:


Expected results:


Additional info:
log:
==========
...

2014-08-07 14:47:33 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.pki.ssh plugin.executeRaw:803 execute-result: ('/usr/share/ovirt-engine/bin/pki-pkcs12-extract.sh', '--name=engine', '--passin=**FILTERED**', '--key=-'), rc=1
2014-08-07 14:47:33 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/pki/ssh.py", line 115, in _misc
    logStreams=False,
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 871, in execute
    command=args[0],
RuntimeError: Command '/usr/share/ovirt-engine/bin/pki-pkcs12-extract.sh' failed to execute
2014-08-07 14:47:33 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': Command '/usr/share/ovirt-engine/bin/pki-pkcs12-extract.sh' failed to execute
...

Comment 1 Simone Tiraboschi 2014-08-07 14:26:39 UTC
Hi Pavel,
why did you set Depends On: 1113974? testik.rhev.lab.eng.brq.redhat.com seams indeed a valid hostname.

Comment 2 Pavel Stehlik 2014-08-07 14:32:46 UTC
Ohh, wrong field, it blocks it :)
fixed

Comment 3 Sandro Bonazzola 2014-08-08 07:14:54 UTC
Unable to reproduce on EL6 with ovirt-3.5-snapshot:

- ovirt-engine-setup-3.5.0-0.0.master.20140807172141.git209ec82.el6.noarch

Can you try updating your environment and giving it another run?

Comment 4 Pavel Stehlik 2014-08-08 11:28:38 UTC
ok with latest


Note You need to log in before you can comment on or make changes to this bug.