Bug 1127776 - Vm failed to migrate when local maintenance activated in hosted-engine environment
Summary: Vm failed to migrate when local maintenance activated in hosted-engine enviro...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.1
Assignee: Francesco Romani
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 14:22 UTC by Artyom
Modified: 2016-02-10 19:41 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.5.1_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-21 16:06:25 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31209 master MERGED Send to cannonizeHostPort port parameter as string instead of integer. Never
oVirt gerrit 35231 ovirt-3.5 MERGED Send to cannonizeHostPort port parameter as string instead of integer. Never

Description Artyom 2014-08-07 14:22:05 UTC
Description of problem:
Vm failed to migrate when local maintenance activated in hosted-engine environment

Version-Release number of selected component (if applicable):
vdsm-4.16.1-6.gita4a4614.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install hosted-engine environment with two hosts
2. Put host with vm to local maintenance (hosted-engine --set-maintenance --mode=local)
3.

Actual results:
Migration failed with exception in vdsm log
Thread-2848::ERROR::2014-08-07 16:40:25,031::migration::259::vm.Vm::(run) vmId=`6538c128-a856-4ab4-a65e-962061eba2a1`::Failed to migrate
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/migration.py", line 229, in run
    self._setupVdsConnection()
  File "/usr/share/vdsm/virt/migration.py", line 92, in _setupVdsConnection
    self._dst, self._vm.cif.bindings['xmlrpc'].serverPort)
  File "/usr/lib64/python2.6/site-packages/vdsm/vdscli.py", line 91, in cannonizeHostPort
    return addr + ':' + port
TypeError: cannot concatenate 'str' and 'int' objects

Expected results:
Vm migrate without any exceptions

Additional info:

Comment 1 Michal Skrivanek 2014-08-22 14:14:40 UTC
looks like HE issue management issue

Comment 2 Jiri Moskovcak 2014-08-25 07:09:24 UTC
look more like vdsm problem -> back to vdsm

Comment 3 Jiri Moskovcak 2014-10-06 13:19:00 UTC
The patch is merged, so moving to POST.

Comment 4 Jiri Moskovcak 2014-10-07 06:46:22 UTC
Sorry, should be MODIFIED, not POST

Comment 5 Sandro Bonazzola 2015-01-15 14:25:58 UTC
This is an automated message: 
This bug should be fixed in oVirt 3.5.1 RC1, moving to QA

Comment 6 Artyom 2015-01-15 16:00:35 UTC
vdsm-4.16.8.1-5.el6ev.x86_64

Comment 7 Sandro Bonazzola 2015-01-21 16:06:25 UTC
oVirt 3.5.1 has been released. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.