Bug 1127777 - [RFE] Log collector does not collect hosted engine information
Summary: [RFE] Log collector does not collect hosted engine information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-log-collector
Version: 3.3.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Gonza
URL: https://github.com/sosreport/sos/issu...
Whiteboard:
: 1169098 (view as bug list)
Depends On:
Blocks: 1208113 1234855
TreeView+ depends on / blocked
 
Reported: 2014-08-07 14:26 UTC by wdaniel
Modified: 2016-03-09 19:59 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
A new plugin has been added to sos 3.2, the sosreport tool, so that information about the hosted-engine setup and high availability daemons is now collected by log collector.
Clone Of:
: 1208113 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:59:02 UTC
oVirt Team: Integration
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0392 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2016-03-10 00:19:00 UTC
oVirt gerrit 31269 master ABANDONED Adding support for ovirt-ha-agent status Never
oVirt gerrit 39342 master MERGED sos: hosts: collect hosted-engine data Never

Description wdaniel 2014-08-07 14:26:20 UTC
Description of problem:

Currently the sosreport tool, used by log collector, does not collect any information related to hosted-engine. These files include, but may not be limited to:

/etc/ovirt-hosted-engine/*
/etc/ovirt-hosted-engine-ha/*
/var/log/ovirt-hosted-engine-ha/*

Version-Release number of selected component (if applicable):


How reproducible:

Very

Steps to Reproduce:
1. Run log collector in hosted engine environment
2. Extract host sosreports in log collector
3.

Actual results:

No hosted-engine related files are found

Expected results:

All hosted-engine configuration and log files should be included

Additional info:

It may also be useful to grab the output from a few 'hosted-engine' commands, similar to the way in which vdsClient output is collected:

# hosted-engine --vm-status

The RHEV-M VM in these situations is completely unaware that it's a VM, no different than running a baremetal RHEV-M. Though there isn't an obvious and easy way to do it inside the guest, would it be useful (or even possible) to somehow indicate that this is a self-hosted environment? Maybe include a file under the log-collector-data directory (like time_diff.txt) that includes a list of all HA hosts? A lot of our customers simply open cases with brief descriptions and a LC, but no information on the environment. Other times, they simply fail to mention self hosted altogether. This small addition would a great convenience.

Comment 1 Sandro Bonazzola 2014-08-13 07:14:56 UTC
Upstream sos plugin request for collecting needed data is here: https://github.com/sosreport/sos/issues/364

We can deliver a sos plugin for hosted-engine within ovirt-hosted-engine-ha or ovirt-hosted-engine-setup for distributions still using sos 2.

Comment 3 Sandro Bonazzola 2014-09-05 08:37:43 UTC
updated after first review:
 - https://www.redhat.com/archives/sos-devel/2014-September/msg00004.html

Comment 4 wdaniel 2014-11-04 18:48:46 UTC
Sandro,

Can we get this backported to 3.5? This feature is extremely helpful for anyone trying to troubleshoot issues with hosted-engine, and it would save a decent amount of time for end users.

Comment 5 Sandro Bonazzola 2014-11-05 07:43:10 UTC
(In reply to wdaniel from comment #4)
> Sandro,
> 
> Can we get this backported to 3.5? This feature is extremely helpful for
> anyone trying to troubleshoot issues with hosted-engine, and it would save a
> decent amount of time for end users.

Proposed for 3.5.1 ZStream

Comment 7 Sandro Bonazzola 2015-03-30 14:36:51 UTC
*** Bug 1169098 has been marked as a duplicate of this bug. ***

Comment 8 Bryn M. Reeves 2015-03-30 15:52:47 UTC
We have a request upstream to make sos tolerant of non-existent plugins on the command-line (so far just for disabled plugins):

  https://github.com/sosreport/sos/issues/537

Not sure this would apply to the lC situation (and it's not going to be in the next RHEL releases) but would appreciate comments on the upstream discussion if this seems like something that could be of interest (I know maintaining the lC command lines in the face of changing plugin sets has caused challenges in the past).

Comment 9 Sandro Bonazzola 2015-04-01 12:25:10 UTC
Thanks Bryn, commented.

Comment 11 Gonza 2015-06-19 07:34:15 UTC
Verified with 

Host:
Red Hat Enterprise Linux Server release 7.1 (Maipo)
ovirt-hosted-engine-ha-1.3.0-0.0.master.20150424113553.20150424113551.git7c14f4c.el7.noarch
ovirt-hosted-engine-setup-1.3.0-0.0.master.20150518075146.gitdd9741f.el7.noarch
sos-3.2-15.el7_1.1.noarch

Hosted-engine:
Red Hat Enterprise Linux Server release 6.7 Beta (Santiago)
ovirt-engine-3.6.0-0.0.master.20150519172219.git9a2e2b3.el6.noarch
ovirt-log-collector-3.6.0-0.1.master.20150416114020.git79bc62d.el6.noarch
sos-3.2-25.el6.noarch

Result file:
http://download.eng.brq.redhat.com/scratch/grafuls/sosreport-LogCollector-20150618164732.tar.xz

Result:
hosted-engine data is now being collected by log-collector.

Comment 15 errata-xmlrpc 2016-03-09 19:59:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0392.html


Note You need to log in before you can comment on or make changes to this bug.