Bug 1127786 - [oVirt-node] ImportError: No module named dmidecode
Summary: [oVirt-node] ImportError: No module named dmidecode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Dan Kenigsberg
QA Contact: Gil Klein
URL:
Whiteboard: node
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 14:40 UTC by Martin Pavlik
Modified: 2016-02-10 19:40 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:26:40 UTC
oVirt Team: Node


Attachments (Terms of Use)
node logs (219.96 KB, application/x-compressed-tar)
2014-08-07 14:40 UTC, Martin Pavlik
no flags Details

Description Martin Pavlik 2014-08-07 14:40:26 UTC
Created attachment 924934 [details]
node logs

Description of problem:
node cannot detect virtualization hardware because of missing module dmidedecode


Version-Release number of selected component (if applicable):
[root@dell-r210ii-06 ~]# cat /etc/redhat-release 
oVirt Node Hypervisor release 3.1.0_master (20140805.0) (Edited, Unsigned)
[root@dell-r210ii-06 ~]# rpm -q vdsm
vdsm-4.16.1-0.gita4d9abf.el6.i686


How reproducible:
100%

Steps to Reproduce:
1. install oVirt node on physical machine
2.
3.

Actual results:
node cannot detect virtualization hardware because of missing module dmidedecode

Expected results:
correct HW etection

Additional info:

MainProcess|Thread-13::DEBUG::2014-08-07 13:55:13,571::supervdsmServer::99::SuperVdsm.ServerCallback::(wrapper) call getHardwareInfo with () {}
MainProcess|Thread-13::ERROR::2014-08-07 13:55:13,572::supervdsmServer::103::SuperVdsm.ServerCallback::(wrapper) Error in getHardwareInfo
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer", line 101, in wrapper
    res = func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer", line 128, in getHardwareInfo
    from dmidecodeUtil import getHardwareInfoStructure
  File "/usr/share/vdsm/dmidecodeUtil.py", line 21, in <module>
    import dmidecode
ImportError: No module named dmidecode

Comment 1 Fabian Deutsch 2014-09-30 10:21:26 UTC
This was likely related to missing SELinux rules. The rules have been updated and dmidecode can be imported (from a shell in userspace).

Comment 2 Sandro Bonazzola 2014-10-17 12:26:40 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.