Bug 11278 - Memory above 64MB not recognised
Summary: Memory above 64MB not recognised
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-07 12:33 UTC by Simon Oldfield
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-10 03:44:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Oldfield 2000-05-07 12:33:07 UTC
I have just installed redhat linux 6.2 onto a PC with 256MB of RAM on an
MS-6153VA ATX VIA Apollo Pro133 Mainboard.  Linux is reporting that there
is only 64MB of RAM.  The BIOS, win95 and win98 all report 256MB of RAM.

Comment 1 Simon Oldfield 2000-05-08 23:58:59 UTC
I got linux to recognise the correct amount of memory by sepcifying the
"mem=256MB" option to lilo.  Is this a BIOS problem or a linux problem?  Is it
simply that this is a new-ish motherboard, and it will all go away at some
point in the future or will I have to explicity set the memory forever more?

Comment 2 Doug Ledford 2000-05-10 03:44:59 UTC
This sounds like your bios doesn't support the extended memory detection call
that the 2.2.14 kernel we ship uses.  This shouldn't be a problem with the 2.4
kernel since it uses the 0e80 call to get the bios memory mapping.  Until then
you will need to keep passing the mem= parameter to the 2.2 kernels on your
machine.

Comment 3 Doug Ledford 2000-05-10 04:06:59 UTC
Duh....that should be the e820 call in the sentences above....technical accuracy
and all...


Note You need to log in before you can comment on or make changes to this bug.