Bug 1127830 - Faulty storage check when having several diskcreation pending jobs
Summary: Faulty storage check when having several diskcreation pending jobs
Keywords:
Status: CLOSED DUPLICATE of bug 1127121
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Vered Volansky
QA Contact: Pavel Stehlik
URL:
Whiteboard: storage
Depends On:
Blocks: 1127121
TreeView+ depends on / blocked
 
Reported: 2014-08-07 15:59 UTC by Ori Gofen
Modified: 2016-05-26 01:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 16:55:51 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm+engine logs (1.86 MB, application/gzip)
2014-08-07 15:59 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-07 15:59:07 UTC
Created attachment 924951 [details]
vdsm+engine logs

Description of problem:
The problem described at bug #1053742 is not adressed in the case of pending jobs.


engine throws several exceptions:

2014-08-04 18:25:44,613 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetAllTasksStatusesVDSCommand] (DefaultQuartzScheduler_Worker-75) Failed in HSMGetAllTasksStatusesVDS method
2014-08-04 18:25:44,614 INFO  [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler_Worker-75) SPMAsyncTask::PollTask: Polling task ec8bfc50-7f59-4a09-b059-dfef5d3f1427 (Parent Command AddDisk, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) returned status finished, result 'cleanSuccess'.
2014-08-04 18:25:44,629 ERROR [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler_Worker-75) BaseAsyncTask::LogEndTaskFailure: Task ec8bfc50-7f59-4a09-b059-dfef5d3f1427 (Parent Command AddDisk, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) ended with failure:
-- Result: cleanSuccess
-- Message: VDSGenericException: VDSErrorException: Failed to HSMGetAllTasksStatusesVDS, error = Cannot zero out volume, code = 374,
-- Exception: VDSGenericException: VDSErrorException: Failed to HSMGetAllTasksStatusesVDS, error = Cannot zero out volume, code = 374
2014-08-04 18:25:44,646 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (DefaultQuartzScheduler_Worker-75) CommandAsyncTask::EndActionIfNecessary: All tasks of command 5c5a7ac1-ff29-4389-9059-020c44f43aaa has ended -> executing endAction
2014-08-04 18:25:44,654 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (DefaultQuartzScheduler_Worker-75) CommandAsyncTask::endAction: Ending action for 1 tasks (command ID: 5c5a7ac1-ff29-4389-9059-020c44f43aaa): calling endAction .
2014-08-04 18:25:44,662 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (org.ovirt.thread.pool-8-thread-23) CommandAsyncTask::EndCommandAction [within thread] context: Attempting to endAction AddDisk, executionIndex: 0
2014-08-04 18:25:44,672 ERROR [org.ovirt.engine.core.bll.AddDiskCommand] (org.ovirt.thread.pool-8-thread-23) [421c4c60] Ending command with failure: org.ovirt.engine.core.bll.AddDiskCommand

Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%

Steps to Reproduce:
Setup: have a storage domain with low space (lets say free_space=5G)

1. Multi-Create several Vm's with preallocated(just to save time) disks until failure (disk_size < 5G )

Actual results:


Expected results:


Additional info:

Comment 1 Allon Mureinik 2014-08-08 16:55:51 UTC

*** This bug has been marked as a duplicate of bug 1127121 ***


Note You need to log in before you can comment on or make changes to this bug.