Bug 1127841 - ProcessOvfUpdateForStorageDomain fails on local domain with NPE
Summary: ProcessOvfUpdateForStorageDomain fails on local domain with NPE
Keywords:
Status: CLOSED DUPLICATE of bug 1129258
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Pavel Stehlik
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 16:27 UTC by Ori Gofen
Modified: 2016-02-10 19:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 11:08:50 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm+engine logs (1.08 MB, application/gzip)
2014-08-07 16:27 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-07 16:27:50 UTC
Created attachment 924958 [details]
vdsm+engine logs

Description of problem:
from engine's log: 

2014-08-07 19:23:24,913 ERROR [org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand] (DefaultQuartzScheduler_Worker-73) [64a204c8] Command org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand throw exception: java.lang.RuntimeException: Exception while building in memory tar of the OVFs of domain e38de544-fdfd-4753-8bbf-fccae8da6153
	at org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand.buildOvfInfoFileByteArray(ProcessOvfUpdateForStorageDomainCommand.java:174) [bll.jar:]
	at org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand.updateOvfStoreContent(ProcessOvfUpdateForStorageDomainCommand.java:193) [bll.jar:]
	at org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand.executeCommand(ProcessOvfUpdateForStorageDomainCommand.java:300) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.executeWithoutTransaction(CommandBase.java:1135) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:1254) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1874) [bll.jar:]
	at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:174) [utils.jar:]
	at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:116) [utils.jar:]
	at org.ovirt.engine.core.bll.CommandBase.execute(CommandBase.java:1275) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.executeAction(CommandBase.java:345) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:430) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runActionImpl(Backend.java:411) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runInternalAction(Backend.java:360) [bll.jar:]
	at sun.reflect.GeneratedMethodAccessor264.invoke(Unknown Source) [:1.7.0_65]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_65]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_65]
	at org.jboss.as.ee.component.ManagedReferenceMethodInterceptorFactory$ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptorFactory.java:72) [jboss-as-ee-7.1.1.Final.jar:7.1.1.Final]

Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Allon Mureinik 2014-08-08 16:57:47 UTC
The "business end" of this stack trace seems to be:

Caused by: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand.buildFilesForOvfs(ProcessOvfUpdateForStorageDomainCommand.java:315) [bll.jar:]
	at org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand.buildOvfInfoFileByteArray(ProcessOvfUpdateForStorageDomainCommand.java:170) [bll.jar:]

Comment 2 Liron Aravot 2014-08-14 11:08:50 UTC

*** This bug has been marked as a duplicate of bug 1129258 ***


Note You need to log in before you can comment on or make changes to this bug.