Bug 1127871 - Suspect metrics report, column "Metric" sort doesn't sort until you click several times [NEEDINFO]
Summary: Suspect metrics report, column "Metric" sort doesn't sort until you click sev...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.2.1
Hardware: All
OS: All
unspecified
medium
Target Milestone: ER01
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords: Triaged
Depends On: 1113707
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 18:03 UTC by John Mazzitelli
Modified: 2018-12-05 19:01 UTC (History)
5 users (show)

(edit)
An issue with the sort order behaviour of the Suspect Metrics Report's "Metric" column caused the sorting icon to indicate a sort order change but the UI would not display the records correctly. For large record results (over 1000), if the user scrolled to the end of list and then scrolled to the start of the list, the sort order began to work correctly until the user left the page. The fix changes the report behaviour to allow server-side sorting on the Resource, Metric, Date/Time and Outlier fields which improves performance. The remaining fields are not sortable server-side and have client-side sorting only allowed (they are sortable after all the data has been loaded to the client).
Clone Of: 1113707
(edit)
Last Closed: 2014-12-11 14:00:29 UTC
jmorgan: needinfo? (mfoley)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 972953 None None None Never

Description John Mazzitelli 2014-08-07 18:03:23 UTC
+++ This bug was initially created as a clone of Bug #1113707 +++

Description of problem:
If you click on title to sort it and scroll to the end of list and scroll to the up again it starts working till you leave page. There are over 1000 records, if there are only a few then it works as expected.

Version-Release number of selected component (if applicable):
3.2.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Michael Burman on 2014-07-07 15:19:02 EDT ---

Changed the behaviour to allow server-side sorting on the Resource, Metric, Date/Time and Outlier fields. Rest of the fields are not sortable server-side and have client side sorting only allowed (they will be sortable after all the data has been loaded to the client).

Fixed in master commit 3fa0ecb.

Comment 1 John Mazzitelli 2014-08-07 20:08:26 UTC
looks like this already made it to the branch:

git cherry-pick -x 3fa0ecb

# On branch release/jon3.3.x
nothing to commit (working directory clean)
The previous cherry-pick is now empty, possibly due to conflict resolution.

Comment 2 Simeon Pinder 2014-08-19 23:50:42 UTC
Moving to ON_QA as available to test in the following brew build:

https://brewweb.devel.redhat.com//buildinfo?buildID=379025


Note You need to log in before you can comment on or make changes to this bug.