Bug 1127872 - Exporting Suspect Metrics report gives blanks for the "Out of Range Factor (%)" column. [NEEDINFO]
Summary: Exporting Suspect Metrics report gives blanks for the "Out of Range Factor (%...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Usability
Version: JON 3.2
Hardware: All
OS: All
high
medium
Target Milestone: ER01
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
Jared MORGAN
URL:
Whiteboard:
Keywords: Triaged
Depends On: 1113183
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 18:04 UTC by John Mazzitelli
Modified: 2018-12-05 19:01 UTC (History)
7 users (show)

(edit)
A bug in the CSV export code for the Suspect Metrics Report caused exported report data to be missing the "Out of Range Factor (%)" column data. The underlying issue with the CSV export code was fixed, and the column data is now included when exported.
Clone Of: 1113183
(edit)
Last Closed: 2014-12-11 13:59:20 UTC
jmorgan: needinfo? (mfoley)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 971303 None None None Never

Description John Mazzitelli 2014-08-07 18:04:06 UTC
+++ This bug was initially created as a clone of Bug #1113183 +++

Description of problem:
Exporting Suspect Metrics report gives blanks for the "Out of Range Factor (%)" column.

Version-Release number of selected component (if applicable):
3.2.0, 3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Reports
2. Select "Suspect Metrics"
3. Notice the values in the "Out of Range Factor (%)" column.
4. Click "Export"
5. Open the CSV file and look at the values in the "Out of Range Factor (%)" column.

Actual results:
Values are all blank for this column

Expected results:
The same values that are seen in the UI should also be in the Export file

Additional info:

--- Additional comment from Michael Burman on 2014-07-07 15:29:21 EDT ---

Fixed in master commit a1e1a79

Comment 1 John Mazzitelli 2014-08-07 20:07:26 UTC
looks like this already made it to the release/3.3.x branch:

# On branch release/jon3.3.x
nothing to commit (working directory clean)
The previous cherry-pick is now empty, possibly due to conflict resolution.

Comment 2 Simeon Pinder 2014-08-19 23:50:27 UTC
Moving to ON_QA as available to test in the following brew build:

https://brewweb.devel.redhat.com//buildinfo?buildID=379025


Note You need to log in before you can comment on or make changes to this bug.