Bug 1127876 - Platform process service CPU Percentage metric returns values that are inconsistent with actual CPU load measurements [NEEDINFO]
Summary: Platform process service CPU Percentage metric returns values that are incons...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER01
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 1091134 1109439 1127875
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 18:06 UTC by John Mazzitelli
Modified: 2019-08-15 03:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the process being monitored was no longer present, or the piql or pid file properties or values were changed, the native library the Platform Management plug-in used to retrieve CPU usage information returned unpredictable values. Improvements to the Platform Management plug-in better handle instances where a process is removed. ProcessComponent no longer adds data to the measurement report if the ProcessInfo instance shows that the process is down.
Clone Of: 1091134
Environment:
Last Closed: 2014-12-11 14:02:05 UTC
Type: Bug
jmorgan: needinfo? (mfoley)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 795963 None None None Never

Comment 1 Jay Shaughnessy 2014-08-08 21:28:26 UTC
Micke, please cherry-pick to release/jon3.3.x as well. Thanks.

Comment 2 Jay Shaughnessy 2014-08-11 13:12:09 UTC
Ignore Comment 1, that was intended for a different bug.

Comment 3 Thomas Segismont 2014-08-19 10:13:22 UTC
Moving to MODIFIED as the fix is the same as for Bug 1109439

See https://bugzilla.redhat.com/show_bug.cgi?id=1109439#c2

Comment 4 Thomas Segismont 2014-08-19 10:17:00 UTC
(In reply to Thomas Segismont from comment #3)
> Moving to MODIFIED as the fix is the same as for Bug 1109439
> 
> See https://bugzilla.redhat.com/show_bug.cgi?id=1109439#c2

Sorry, wrong references. Actually, the fix is the same as for Bug 1127875

See https://bugzilla.redhat.com/show_bug.cgi?id=1127875#c1

Comment 5 Jay Shaughnessy 2014-08-26 22:11:25 UTC
In that case I think we can move to ON_QA, because the other BZ is ON_QA.


Note You need to log in before you can comment on or make changes to this bug.