Bug 1127884 - rhel-x86_64-server-6-ost-(5|foreman) channel maps are missing from channel-cert-mapping.txt
Summary: rhel-x86_64-server-6-ost-(5|foreman) channel maps are missing from channel-ce...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jesus M. Rodriguez
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-07 18:27 UTC by John Sefler
Modified: 2014-10-14 07:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2014-08-07 18:27:54 UTC
Description of problem:

RHN Classic channel 'rhel-x86_64-server-6-ost-foreman' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-ost-foreman-debuginfo' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-ost-5' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-ost-5-debuginfo' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.12.10-1.el6.x86_64


How reproducible:


Steps to Reproduce:

[root@jsefler-6 ~]# grep server-6-ost /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ost-3: OpenStack-x86_64-b374f251d014-191.pem
rhel-x86_64-server-6-ost-3-debuginfo: OpenStack-x86_64-b374f251d014-191.pem
rhel-x86_64-server-6-ost-4: OpenStack-4.0-x86_64-246d432e005c-191.pem
rhel-x86_64-server-6-ost-4-cts: OpenStack-4.0-CTS-x86_64-8fe420f53388-208.pem
rhel-x86_64-server-6-ost-4-cts-debuginfo: OpenStack-4.0-CTS-x86_64-8fe420f53388-208.pem
rhel-x86_64-server-6-ost-4-debuginfo: OpenStack-4.0-x86_64-246d432e005c-191.pem
rhel-x86_64-server-6-ost-beta: OpenStack-Beta-x86_64-2046a38a8a9f-220.pem
rhel-x86_64-server-6-ost-beta-cts: OpenStack-Beta-CTS-x86_64-d7a59cfd2249-221.pem
rhel-x86_64-server-6-ost-beta-cts-debuginfo: OpenStack-Beta-CTS-x86_64-d7a59cfd2249-221.pem
rhel-x86_64-server-6-ost-beta-debuginfo: OpenStack-Beta-x86_64-2046a38a8a9f-220.pem
rhel-x86_64-server-6-ost-folsom: Server-OpenStack-x86_64-0b9893c79701-191.pem
rhel-x86_64-server-6-ost-folsom-debuginfo: Server-OpenStack-x86_64-0b9893c79701-191.pem
rhel-x86_64-server-6-ost-preview: Server-OpenStack-x86_64-b83069ace8bd-191.pem
rhel-x86_64-server-6-ost-preview-debuginfo: Server-OpenStack-x86_64-b83069ace8bd-191.pem

Actual results:
above

Expected results:
also expected list to include channels maps for...
rhel-x86_64-server-6-ost-foreman
rhel-x86_64-server-6-ost-foreman-debuginfo
rhel-x86_64-server-6-ost-5
rhel-x86_64-server-6-ost-5-debuginfo


Additional info:
Before this bug can be fixed in subscription-manager-migration-data, an upstream fix to http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/cdn/product-certs.json must be done by Release Engineering.

Comment 1 Jesus M. Rodriguez 2014-08-13 19:23:49 UTC
Will be picked up in next build of migration-data.

Comment 3 Sharath Dwaral 2014-08-15 15:19:19 UTC
Version:

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.23-1
subscription management rules: 5.11
subscription-manager: 1.12.12-1.el6
python-rhsm: 1.12.5-1.el6

# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.11-1.el6.noarch


Verification:

# grep server-6-ost-5 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt

>>rhel-x86_64-server-6-ost-5: OpenStack-5.0-x86_64-4dbb67de7a84-191.pem
  rhel-x86_64-server-6-ost-5-cts: OpenStack-5.0-CTS-x86_64-fe7f145d82b8-208.pem
  rhel-x86_64-server-6-ost-5-cts-debuginfo: OpenStack-5.0-CTS-x86_64-fe7f145d82b8-208.pem
>>rhel-x86_64-server-6-ost-5-debuginfo: OpenStack-5.0-x86_64-4dbb67de7a84-191.pem

# grep server-6-ost-foreman /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt

>>rhel-x86_64-server-6-ost-foreman: OpenStack-Foreman-x86_64-2810bb9b4a38-191.pem
>>rhel-x86_64-server-6-ost-foreman-debuginfo: OpenStack-Foreman-x86_64-2810bb9b4a38-191.pem

The channels that were missing as metion in comment1 are present in the latest sub-man-migration-data.

VERIFIED

Comment 4 errata-xmlrpc 2014-10-14 07:48:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.