Bug 1127900 - rhel-x86_64-server-6-rhs-(3|rhsc-3|nagios) channel maps are missing from channel-cert-mapping.txt
Summary: rhel-x86_64-server-6-rhs-(3|rhsc-3|nagios) channel maps are missing from chan...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alex Wood
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel67
TreeView+ depends on / blocked
 
Reported: 2014-08-07 19:22 UTC by John Sefler
Modified: 2015-07-22 06:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:52:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1345 normal SHIPPED_LIVE subscription-manager and python-rhsm bug fix and enhancement update 2015-07-20 17:59:53 UTC

Description John Sefler 2014-08-07 19:22:25 UTC
Description of problem:

RHN Classic channel 'rhel-x86_64-server-6-rhs-3-debuginfo' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-rhs-rhsc-3-debuginfo' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-rhs-rhsc-3' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-rhs-nagios-3' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-rhs-nagios-3-debuginfo' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.10-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# grep server-6-rhs- /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhs-2.0: RHS-OnPremise-x86_64-5ae5a63102f0-186.pem
rhel-x86_64-server-6-rhs-2.0-debuginfo: RHS-OnPremise-x86_64-5ae5a63102f0-186.pem
rhel-x86_64-server-6-rhs-2.1: RHS-OnPremise-x86_64-7f601d986c85-186.pem
rhel-x86_64-server-6-rhs-2.1-debuginfo: RHS-OnPremise-x86_64-7f601d986c85-186.pem
rhel-x86_64-server-6-rhs-rhsc-2.0: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.0-debuginfo: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.1: RHS-Console-x86_64-7363b55ffb92-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.1-debuginfo: RHS-Console-x86_64-7363b55ffb92-188.pem
[root@jsefler-6 ~]# 


Actual results:
above

Expected results:
also expected the output to include maps for channels...
rhel-x86_64-server-6-rhs-3-debuginfo
rhel-x86_64-server-6-rhs-rhsc-3
rhel-x86_64-server-6-rhs-rhsc-3-debuginfo
rhel-x86_64-server-6-rhs-nagios-3
rhel-x86_64-server-6-rhs-nagios-3-debuginfo


Additional info:
Before this bug can be fixed in subscription-manager-migration-data, an upstream fix to http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/cdn/product-certs.json must be done by Release Engineering.

Comment 1 Andrew Thomas 2014-09-29 18:17:51 UTC
All of these mappings have been updated. Please re-test.

Comment 2 Bryan Kearney 2014-11-03 19:48:11 UTC
Moving bugs to 6.7

Comment 3 Bryan Kearney 2014-11-03 19:49:11 UTC
Moving bugs to 6.7

Comment 4 Bryan Kearney 2014-11-03 19:53:55 UTC
Moving bugs to 6.7

Comment 6 Devan Goodwin 2014-11-24 13:16:22 UTC
Should be fixed as of subscription-manager-migration-data-2.0.1

Comment 7 John Sefler 2014-12-01 16:17:51 UTC
(In reply to Devan Goodwin from comment #6)
> Should be fixed as of subscription-manager-migration-data-2.0.1
version typo?

subscription-manager-migration-data-2.0.13-1.el6 was released on RHEL6.6

subscription-manager-migration-data-2.0.13-1.el6 contains does NOT contain the expected mappings from comment 0.

I have verified comment 1.  The mappings have been fixed upstream.

This bug will be fixed once subscription-manager-migration-data is regenerated/rebuilt for el6.

Comment 9 Shwetha Kallesh 2015-04-13 08:27:30 UTC
Missing Channel maps are added to channel-cert-mapping.txt

[root@dhcp35-135 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.47-1
subscription management rules: 5.14
subscription-manager: 1.14.3-1.el6
python-rhsm: 1.14.2-1.el6


[root@dhcp35-135 ~]# grep server-6-rhs- /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhs-2.0: RHS-OnPremise-x86_64-5ae5a63102f0-186.pem
rhel-x86_64-server-6-rhs-2.0-debuginfo: RHS-OnPremise-x86_64-5ae5a63102f0-186.pem
rhel-x86_64-server-6-rhs-2.1: RHS-OnPremise-x86_64-7f601d986c85-186.pem
rhel-x86_64-server-6-rhs-2.1-debuginfo: RHS-OnPremise-x86_64-7f601d986c85-186.pem
rhel-x86_64-server-6-rhs-3: RHS-OnPremise-x86_64-cdbde10f1a46-186.pem
rhel-x86_64-server-6-rhs-3-debuginfo: RHS-OnPremise-x86_64-cdbde10f1a46-186.pem
rhel-x86_64-server-6-rhs-bigdata-3: RHS-OnPremise-x86_64-cdbde10f1a46-186.pem
rhel-x86_64-server-6-rhs-bigdata-3-debuginfo: RHS-OnPremise-x86_64-cdbde10f1a46-186.pem
rhel-x86_64-server-6-rhs-nagios-3: RHS-Nagios-x86_64-1805d3f1aa9e-270.pem
rhel-x86_64-server-6-rhs-nagios-3-debuginfo: RHS-Nagios-x86_64-1805d3f1aa9e-270.pem
rhel-x86_64-server-6-rhs-rhsc-2.0: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.0-debuginfo: RHS-Console-x86_64-3c77c5245214-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.1: RHS-Console-x86_64-7363b55ffb92-188.pem
rhel-x86_64-server-6-rhs-rhsc-2.1-debuginfo: RHS-Console-x86_64-7363b55ffb92-188.pem
rhel-x86_64-server-6-rhs-rhsc-3: RHS-Console-x86_64-65ff1c734642-188.pem
rhel-x86_64-server-6-rhs-rhsc-3-debuginfo: RHS-Console-x86_64-65ff1c734642-188.pem

Comment 10 errata-xmlrpc 2015-07-22 06:52:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1345.html


Note You need to log in before you can comment on or make changes to this bug.