Bug 1127903 - rhel-x86_64-server-6-rhevm-3.5 channel maps are missing from channel-cert-mapping.txt
Summary: rhel-x86_64-server-6-rhevm-3.5 channel maps are missing from channel-cert-map...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-07 19:35 UTC by John Sefler
Modified: 2014-10-14 07:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2014-08-07 19:35:27 UTC
Description of problem:

RHN Classic channel 'rhel-x86_64-server-6-rhevm-3.5' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>

RHN Classic channel 'rhel-x86_64-server-6-rhevm-3.5-debuginfo' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt'. expected:<true> but was:<false>


Version-Release number of selected component (if applicable):
[root@jsefler-6]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.10-1.el6.noarch

How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# grep rhel-x86_64-server-6-rhevm-3 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhevm-3: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3-beta: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3-beta-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.1: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.1-debuginfo: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.2: rhev-x86_64-993085fd26ef-150.pem
rhel-x86_64-server-6-rhevm-3.2-debuginfo: rhev-x86_64-993085fd26ef-150.pem
rhel-x86_64-server-6-rhevm-3.3: rhev-x86_64-528e9b371346-150.pem
rhel-x86_64-server-6-rhevm-3.3-debuginfo: rhev-x86_64-528e9b371346-150.pem
rhel-x86_64-server-6-rhevm-3.4: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.4-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem
[root@jsefler-6 ~]# 


Actual results:
above

Expected results:
also expected mappings for channels...
rhel-x86_64-server-6-rhevm-3.5
rhel-x86_64-server-6-rhevm-3.5-debuginfo


Additional info:
Before this bug can be fixed in subscription-manager-migration-data, an upstream fix to http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/cdn/product-certs.json must be done by Release Engineering.

Comment 1 Jesus M. Rodriguez 2014-08-13 20:18:58 UTC
As of today, still no 3.5 mappings.

Comment 2 Jesus M. Rodriguez 2014-08-21 21:40:44 UTC
$ grep rhel-x86_64-server-6-rhevm-3 channel-cert-mapping.txt 
rhel-x86_64-server-6-rhevm-3: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3-beta: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3-beta-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.1: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.1-debuginfo: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.2: rhev-x86_64-993085fd26ef-150.pem
rhel-x86_64-server-6-rhevm-3.2-debuginfo: rhev-x86_64-993085fd26ef-150.pem
rhel-x86_64-server-6-rhevm-3.3: rhev-x86_64-528e9b371346-150.pem
rhel-x86_64-server-6-rhevm-3.3-debuginfo: rhev-x86_64-528e9b371346-150.pem
rhel-x86_64-server-6-rhevm-3.4: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.4-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem

No 3.5 mappings

Comment 3 Andrew Thomas 2014-09-02 18:29:06 UTC
rhevm-3.5 should be in the newest version of product-certs.json. Please re-test.

Comment 4 John Sefler 2014-09-08 15:46:10 UTC
I now see mappings for the following channels in the latest product-certs.json.
Next we need a new build of subscription-manager-migration-data to pull them in.

rhel-x86_64-server-6-rhevm-3.5
rhel-x86_64-server-6-rhevm-3.5-debuginfo

Comment 6 John Sefler 2014-09-08 19:39:48 UTC
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.13-1.el6.noarch

[root@jsefler-6 ~]# grep rhel-x86_64-server-6-rhevm-3 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhevm-3: rhev-x86_64-a52ba7adce1b-150.pem
rhel-x86_64-server-6-rhevm-3-beta: rhev-x86_64-a52ba7adce1b-150.pem
rhel-x86_64-server-6-rhevm-3-beta-debuginfo: rhev-x86_64-a52ba7adce1b-150.pem
rhel-x86_64-server-6-rhevm-3-debuginfo: rhev-x86_64-a52ba7adce1b-150.pem
rhel-x86_64-server-6-rhevm-3.1: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.1-debuginfo: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.2: rhev-x86_64-993085fd26ef-150.pem
rhel-x86_64-server-6-rhevm-3.2-debuginfo: rhev-x86_64-993085fd26ef-150.pem
rhel-x86_64-server-6-rhevm-3.3: rhev-x86_64-528e9b371346-150.pem
rhel-x86_64-server-6-rhevm-3.3-debuginfo: rhev-x86_64-528e9b371346-150.pem
rhel-x86_64-server-6-rhevm-3.4: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.4-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.5: rhev-x86_64-a52ba7adce1b-150.pem
rhel-x86_64-server-6-rhevm-3.5-debuginfo: rhev-x86_64-a52ba7adce1b-150.pem
[root@jsefler-6 ~]# 


VERIFIED: channel-to-productCert mappings for rhevm-3.5 channels are now included in subscription-manager-migration-data

Comment 7 errata-xmlrpc 2014-10-14 07:48:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.