Bug 1127915 - staypuft neutron network failed with "no implicit conversion of nil to string"
Summary: staypuft neutron network failed with "no implicit conversion of nil to string"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z2
: Installer
Assignee: Jason Guiditta
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 20:06 UTC by Ofer Blaut
Modified: 2016-04-26 21:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:01:53 UTC


Attachments (Terms of Use)
logs (9.38 KB, text/plain)
2014-08-07 20:06 UTC, Ofer Blaut
no flags Details
YAML file of the node with the issue (4.48 KB, text/html)
2014-08-22 09:09 UTC, Ramon Acedo
no flags Details
YAML file of offending node (new deployment with net.ifnames=0) (4.71 KB, text/html)
2014-08-22 16:52 UTC, Ramon Acedo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Ofer Blaut 2014-08-07 20:06:02 UTC
Created attachment 925016 [details]
logs

Description of problem:

staypuft neutron network stuck deployment in 60%

Error attached , all interfaces are up and running

enp4s0f1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 3.3.3.3  netmask 255.255.255.0  broadcast 3.3.3.255
        inet6 fe80::82c1:6eff:fe07:d24c  prefixlen 64  scopeid 0x20<link>
        ether 80:c1:6e:07:d2:4c  txqueuelen 1000  (Ethernet)
        RX packets 737452  bytes 47698284 (45.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 20  bytes 2916 (2.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 

This installation is on bare metal 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Mike Burns 2014-08-07 22:58:49 UTC
Error: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Error: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Wrapped exception:
no implicit conversion of nil into String
Error: /Stage[main]/Neutron::Agents::Ovs/Neutron::Plugins::Ovs::Port[br-ex:enp4s0f1]/Vs_port[enp4s0f1]/ensure: change from absent to present failed: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Notice: /Stage[main]/Neutron::Agents::Ovs/Service[neutron-plugin-ovs-service]: Dependency Vs_port[enp4s0f1] has failures: true
Warning: /Stage[main]/Neutron::Agents::Ovs/Service[neutron-plugin-ovs-service]: Skipping because of failed dependencies

Comment 4 Mike Orazi 2014-08-12 19:34:48 UTC
Looks like bad validation/param entry.  Can you reproduce and attach the yaml for the offending node please?

Comment 5 Jason Guiditta 2014-08-20 18:30:09 UTC
This may be a dup of the opm bug against vswitch, so it would also be good to see if it reproduces with the lasted (20-2)

Comment 6 Ramon Acedo 2014-08-22 09:09:07 UTC
Created attachment 929493 [details]
YAML file of the node with the issue

I also found this only when configuring a external NIC for the Networker node.

In response to Comment #4 I'm attaching the YAML file of the affected node in my environment.

Comment 7 Jason Guiditta 2014-08-22 14:51:34 UTC
Is this really the same machine used in the report?  the names for the nic don't match at all, if so:
ovs_bridge_uplinks:
    - br-ex:eno50336512
ui::neutron::compute_tenant_interface: eno33557248
ui::neutron::external_interface_name: eno50336512
ui::neutron::networker_tenant_interface: eno33557248 

The enp4s0f1 nic is nowhere to be found.  If this is a different setup from that reported, perhaps this is a red herring, otherwise, I don't see how this could work as it.  Lastly, can someone please tell me what versions you are using of bot openstack-foreman-installer and openstack-puppet-modules?

Comment 8 Ramon Acedo 2014-08-22 15:14:07 UTC
No it's not. I just provided mine if that helps as I am hitting the issue reported here. I've no relation with the environment used by the original reporter of the bug.

Comment 9 Ramon Acedo 2014-08-22 16:52:40 UTC
Created attachment 929714 [details]
YAML file of offending node (new deployment with net.ifnames=0)

This is with a different deployment also on VMware Fusion but with net.ifnames=0 so I get eth2 instead of eno5XXXX. I get this:

Error: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Error: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Wrapped exception:
no implicit conversion of nil into String
Error: /Stage[main]/Neutron::Agents::Ovs/Neutron::Plugins::Ovs::Port[br-ex:eth2]/Vs_port[eth2]/ensure: change from absent to present failed: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Notice: /Stage[main]/Quickstack::Neutron::Firewall::Vxlan/Firewall[002 vxlan udp]/ensure: created
Notice: /Stage[main]/Neutron::Agents::Ovs/Service[neutron-plugin-ovs-service]: Dependency Vs_port[eth2] has failures: true
Warning: /Stage[main]/Neutron::Agents::Ovs/Service[neutron-plugin-ovs-service]: Skipping because of failed dependencies

Attached the YAML

Comment 11 Jason Guiditta 2014-10-01 18:46:04 UTC
Is this still an issue?  I just tried it with current versions of ofi and opm, and cannot reproduce

Comment 12 Ofer Blaut 2014-10-02 09:22:34 UTC
Issue is not seen on latest rhel-osp-installer

will reopen if encounter it

Comment 15 errata-xmlrpc 2014-11-04 17:01:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.