Bug 112792 - Installer fails with rpmdb: fatal region detected message
Installer fails with rpmdb: fatal region detected message
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2003-12-31 18:58 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-05 11:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-12-31 18:58:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Got an rpmdb error while installing FC 1 in the graphical mode. 
Somewhere in the middle of the installation I switched to F1 screen 
and saw tons of "rpmdb: fatal region detected; run recovery" 
messages. It does not really matter what to select to install, but 
rather the number of packages to install: installing the very minimal 
configuration does not seem to produce such an error. 
After the installation is finished I can not boot into Linux.
I have tried this several times with no success.
Looks like it installs some number of first packages and than does 
not install the rest because of this error.
I have installed RH 8 on this machin with no problems. But both RH9 
and FC1 fails with the identical errors.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start the installation process on my computer
2. Switch to F1 screen and observe....

Additional info:

This problem is very well reproducable on my computer. The CDs are 
fine, I checked them. The HDD is ok too.
I realize there is not much information in this posting to try to 
isolate the problem, but if you tell me what information is needed I 
will provide it.
Comment 1 Jeremy Katz 2004-01-03 15:47:34 EST
So the CDs have been checked with the built-in mediacheck
functionality?  If so, can you boot with 'linux allowcddma' and see if
that helps?
Comment 2 Steven Gallacher 2004-03-17 10:24:43 EST

I tried the linux allowcddma boot option, but same failure occurred. 
(rpmdb failures).  
I don't know whether the same file was causing the problem or not.

Hope this helps.

I also get the same error in an NFS RH9 installation as well.  Haven't
tried any earlier versions as I don't have media here.
Comment 3 Tim Behrsin 2004-03-28 00:34:47 EST
I get the same errors.

When looking at anaconda's install.log file, it reports:
"Error: db4 error(-30978) from db->curso: DB_RUNRECOVERY: Fatal error,
run database recovery"

multiple times.

This is on both Core 1 and Core 2 test.

I do not get this error message on RH9's anaconda.
Comment 4 Tim Behrsin 2004-03-28 00:36:19 EST
Oh... and I've checked RAM with several passes of memtest86 to no avail.
Comment 5 Jeremy Katz 2004-10-05 11:57:44 EDT
This should be better in newer releases.

Note You need to log in before you can comment on or make changes to this bug.