Bug 1127922 - Heat messaging failure using default qpid_topology_version=1
Summary: Heat messaging failure using default qpid_topology_version=1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: z1
: 5.0 (RHEL 6)
Assignee: Zane Bitter
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On: 1124137 1125997
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 20:39 UTC by Zane Bitter
Modified: 2016-04-26 17:43 UTC (History)
12 users (show)

Fixed In Version: openstack-heat-2014.1.1-2.3.el6ost
Doc Type: Bug Fix
Doc Text:
The Qpid driver's v2 topology has been introduced to specifically address the slow growth of orphaned direct exchanges over time. By default, however, services still used the original v1 topology of the Qpid driver. The v2 topology had to be explicitly configured via the 'qpid_topology_version = 2' parameter. With this fix, the Orchestration service's distribution configuration file (/usr/share/heat/heat-dist.conf) now contains the 'qpid_topology_version = 2' parameter. This effectively sets the Qpid driver's v2 topology as the default. In addition, the default value in the Qpid implementation has been changed to 2 as well.
Clone Of: 1125997
Environment:
Last Closed: 2014-09-30 17:52:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1344 normal SHIPPED_LIVE openstack-heat bug fix advisory 2014-09-30 21:49:55 UTC

Comment 2 Amit Ugol 2014-09-14 07:12:58 UTC
Tested on:
RHEL 6.5
heat package version 2014.1.2-2.1.el6ost
heat version 0.2.9

After following the steps, the bug does not reproduce.

Comment 5 errata-xmlrpc 2014-09-30 17:52:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1344.html


Note You need to log in before you can comment on or make changes to this bug.