Bug 112802 - rpm command segmentation faults after upgrading glibc and binutils
rpm command segmentation faults after upgrading glibc and binutils
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-01 17:12 EST by gromit
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-03 02:19:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of rpm -e perl-PerlMagick (250.67 KB, text/plain)
2004-01-02 11:20 EST, gromit
no flags Details

  None (edit)
Description gromit 2004-01-01 17:12:21 EST
Description of problem:

I'm having the exact same problem as described in #92312.  The 
problem is that the rpm command yields the following results:

{root@drzaius opt]# rpm -Uvh <insert random rpm here>.rpm 
Preparing...                
########################################### [100%]
Segmentation fault (core dumped)
[root@drzaius opt]# rpm -ivh <insert random rpm here>.rpm 
Preparing...                
########################################### [100%]
Segmentation fault (core dumped)
[root@drzaius opt]# rpm -e <insert random rpm here>
Segmentation fault (core dumped)


It appears to have happened when I upgraded to glibc-2.3 just like 
ddionne did, only in my case I was installing ImageMagick instead of 
a kernel...

[root@drzaius opt]# rpm -qa|grep glibc
glibc-2.3.2-27.9.7
glibc-devel-2.3.2-27.9.7
glibc-common-2.3.2-27.9.7

I have the same problem in that -v -q and everything else works, just 
not -i -U -e or anything that actually manipulates packages.  I have 
tried upgrading RPM with the binary packages for 4.1 on rpm.org, and 
that doesn't help, nor does going back to 4.0.4.  I'm pretty sure 
it's related to glibc, but I have no idea where to go from here...


Version-Release number of selected component (if applicable):


How reproducible:

Every Time...

Steps to Reproduce:
1. Upgraded glibc to 2.3, upgraded binutils
2. All rpm query commands (-v -q etc...) work fine
3. All rpm manipulation commands (-i -U -e) yield "Segmentation fault 
(core dumped)"
  
Actual results:

Core Dumping/Seg Faults

Expected results:

Lack of Seg Faults, and actual package installation/removal/upgrades
Comment 1 Jeff Johnson 2004-01-02 03:17:11 EST
Can you attach an strace of a failing command? I might be able
to guess.

Meanwhile, are there other problems or just rpm segfaulting?
Comment 2 gromit 2004-01-02 10:50:48 EST
Funny you should mention that =)  I discovered this last night:

[schultz@drzaius:schultz]$ su - gromit@rootmonkey.net
su: relocation error: /lib/libnss_files.so.2: symbol 
_nss_files_parse_pwent, version GLIBC_2.0 not defined in file 
libc.so.6 with link time reference
[schultz@drzaius:schultz]$ 

So it looks like I broke glibc, not rpm.  Any suggestions on re-
installing glibc from source?  Preferred versions?

Thanks!
Comment 3 gromit 2004-01-02 10:53:31 EST
Sorry, I should mention that using "su" to become root works fine, 
but this server has Ensim installed and the user mentioned above is a 
virtual site user, which uses "@domain.com" in the username...
Comment 4 gromit 2004-01-02 11:16:41 EST
And the plot thickens:

root@ns1 /root]# cat strace.rpm.txt |mail -v 
rootmonkey@rootmonkey.net -s strac 
rootmonkey@rootmonkey.net... Connecting to rootmonkey.net via 
virthostmail...
/usr/sbin/sendmail: /lib/ld-linux.so.2: version `GLIBC_PRIVATE' not 
found (required by /lib/libc.so.6)
Comment 5 gromit 2004-01-02 11:20:30 EST
Created attachment 96742 [details]
Strace of rpm -e perl-PerlMagick

Here's that strace.
Comment 6 Jeff Johnson 2004-01-03 02:19:57 EST
Hmmm, you're pretty thoroughly screwed.

Reinstall is the easiest way out.

Otherwise, you need to boot rescue mode with
busybox and reinstall the glibc packages using the
builtin rpm command in busybox. Explaining the whole
procedure is, well, a lot of work.

Notabug because this is a glibc misinstall, not an rpm problem.

Note You need to log in before you can comment on or make changes to this bug.