Bug 1128038 - tracebacks on dnf/tests/support.py
Summary: tracebacks on dnf/tests/support.py
Keywords:
Status: CLOSED DUPLICATE of bug 1126815
Alias: None
Product: Fedora
Classification: Fedora
Component: pylint
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 07:12 UTC by Ales Kozumplik
Modified: 2014-10-17 00:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 00:22:02 UTC


Attachments (Terms of Use)

Description Ales Kozumplik 2014-08-08 07:12:40 UTC
pylint crashes on this file: https://github.com/akozumpl/dnf/blob/f8c58e2d2d316d824a196b3c4c26a9a149d69746/tests/support.py

$ pylint tests/support.py

Traceback (most recent call last):
  File "/usr/bin/pylint", line 9, in <module>
    load_entry_point('pylint==1.2.0', 'console_scripts', 'pylint')()
  File "/usr/lib/python2.7/site-packages/pylint/__init__.py", line 21, in run_pylint
    Run(sys.argv[1:])
  File "/usr/lib/python2.7/site-packages/pylint/lint.py", line 1047, in __init__
    linter.check(args)
  File "/usr/lib/python2.7/site-packages/pylint/lint.py", line 626, in check
    self.check_astroid_module(astroid, walker, rawcheckers, tokencheckers)
  File "/usr/lib/python2.7/site-packages/pylint/lint.py", line 712, in check_astroid_module
    walker.walk(astroid)
  File "/usr/lib/python2.7/site-packages/pylint/utils.py", line 715, in walk
    self.walk(child)
  File "/usr/lib/python2.7/site-packages/pylint/utils.py", line 715, in walk
    self.walk(child)
  File "/usr/lib/python2.7/site-packages/pylint/utils.py", line 712, in walk
    cb(astroid)
  File "/usr/lib/python2.7/site-packages/pylint/checkers/newstyle.py", line 135, in visit_function
    args=(call.args[0].name, ))
AttributeError: 'Getattr' object has no attribute 'name'

Comment 1 Ales Kozumplik 2014-08-08 07:14:54 UTC
Installed Packages
pylint.noarch                                             1.2-6.fc20                                             @System

Comment 3 Brian Lane 2014-10-17 00:22:02 UTC

*** This bug has been marked as a duplicate of bug 1126815 ***


Note You need to log in before you can comment on or make changes to this bug.