Bug 1128062 - Unable to set watchdog for a VM from German version of RHEV UI
Summary: Unable to set watchdog for a VM from German version of RHEV UI
Keywords:
Status: CLOSED DUPLICATE of bug 1128498
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Martin Sivák
QA Contact: Pavel Stehlik
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 08:17 UTC by akotov
Modified: 2019-04-28 09:31 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-28 10:42:40 UTC
oVirt Team: SLA


Attachments (Terms of Use)

Description akotov 2014-08-08 08:17:03 UTC
Description of problem:

You can select the device and the action however after clickign 'Save' both settings are gone. Inside the virtual machine there is no device. Repeating the same steps with an English RHEV UI works as expected.


Version-Release number of selected component (if applicable):

rhevm-webadmin-portal-3.4.1-0.31.el6ev.noarch

How reproducible:

Always

Steps to Reproduce:
1. Switch RHEV UI to German
2. Edit VM properties => Advanced => Hohe Verfügbarkeit => 

watchdog model - i6300esb
action -  abschalten


3. Click OK

Actual results:

Edit VM properties => Advanced => Hohe Verfügbarkeit => watchdog fields are clear, error in the engine.log:

2014-08-08 10:16:42,663 WARN  [org.ovirt.engine.core.bll.AddWatchdogCommand] (ajp-/127.0.0.1:8702-5) [267732] CanDoAction of action AddWatchdog failed. Reasons:WATCHDOG_ACTION_REQUIRED


Expected results:

Watchdog is set correctly

Additional info:

There are also other actions for a watchdog that produce different errors in the engine.log, for example for one action i've seen:

2014-08-07 17:30:27,166 ERROR [org.ovirt.engine.core.bll.UpdateWatchdogCommand] (ajp-/127.0.0.1:8702-1) [5d7587d6] Command org.ovirt.engine.core.bll.UpdateWatchdogCommand throw exception: java.lang.NullPointerEx
ception
        at org.ovirt.engine.core.bll.AbstractVmWatchdogCommand.getSpecParams(AbstractVmWatchdogCommand.java:48) [bll.jar:]
        at org.ovirt.engine.core.bll.UpdateWatchdogCommand.executeCommand(UpdateWatchdogCommand.java:20) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeWithoutTransaction(CommandBase.java:1133) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:1218) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1894) [bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInRequired(TransactionSupport.java:151) [utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:118) [utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.execute(CommandBase.java:1238) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeAction(CommandBase.java:351) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:415) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runActionImpl(Backend.java:394) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runInternalAction(Backend.java:343) [bll.jar:]
        at sun.reflect.GeneratedMethodAccessor94.invoke(Unknown Source) [:1.7.0_65]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_65]
        at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_65]



English UI works as expected for all watchdog/actions combinations

Comment 1 Doron Fediuck 2014-08-28 10:42:40 UTC
There's a generic issue with several languages, and this is not German specific.
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 1128498 ***


Note You need to log in before you can comment on or make changes to this bug.