Bug 1128072 - Need to show the whole NIC names in Network page
Summary: Need to show the whole NIC names in Network page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ryan Barry
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-08-08 08:52 UTC by wanghui
Modified: 2016-03-09 14:13 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:13:06 UTC
oVirt Team: Node


Attachments (Terms of Use)
nic_name screen shot (150.45 KB, image/png)
2014-08-08 08:52 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 33345 master MERGED Drop the MAC from the network page if systemd Never

Description wanghui 2014-08-08 08:52:05 UTC
Created attachment 925125 [details]
nic_name screen shot

Description of problem:
It should show the whole NIC names in Network page to avoid misunderstanding.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140807.0.iso
ovirt-node-3.1.0-0.6.20140731git2c8e71f.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install  rhev-hypervisor7-7.0-20140807.0.iso
2. Check the NIC name in Network page.
3. Check the NIC details.

Actual results:
1. After step2, it have two NICs are named as the same name 'enp32s0'.
2. After step3, you can find one NIC named as 'enp32s0f0' while another is named as 'enp32s0f1'.

Expected results:
1. It should show the whole nic's name to avoid misunderstanding.

Additional info:

Comment 1 Ryan Barry 2014-08-10 23:43:59 UTC
It looks like it's possible to hit the 15-character limit on ifdev names pretty easily here. 80x24 is going to be hard, even if dynamically size this based on the longest name present in the system.

Do we want to shorten the manufacturer field in order to show this? Determine dynamically or to 15 characters?

Comment 2 Fabian Deutsch 2014-09-24 14:40:26 UTC
Currently we show
Device, Status, Model, MAC Address

I can imagine that we
a) Abbreviate the status i.e. (C)onfigured, (U)nconfigured (M)anaged
b) Drop the MAC address, because the Device name provides much more informations on el7, than on el6

Looking at the output of nmcli, I'd choose b).
The mac address can still be viewed in the details dialog, it will just vanish from the overview.

Thoughts?

Comment 3 Ying Cui 2014-09-26 08:05:11 UTC
(In reply to Fabian Deutsch from comment #2)
> Currently we show
> Device, Status, Model, MAC Address
> 
> I can imagine that we
> a) Abbreviate the status i.e. (C)onfigured, (U)nconfigured (M)anaged
> b) Drop the MAC address, because the Device name provides much more
> informations on el7, than on el6
> 
> Looking at the output of nmcli, I'd choose b).
> The mac address can still be viewed in the details dialog, it will just
> vanish from the overview.
> 
> Thoughts?

Fabian, rhevh 6.6 with node 3.1 is still for RHEV 3.5 GA, so if you move the MAC, it is not good display for el6.

Comment 4 Ying Cui 2014-09-26 08:06:34 UTC
According to comment 3, I change this bug status to ASSIGNED to re-design.

Comment 5 Fabian Deutsch 2014-09-29 06:47:17 UTC
(In reply to Ying Cui from comment #3)
> (In reply to Fabian Deutsch from comment #2)
> > Currently we show
> > Device, Status, Model, MAC Address
> > 
> > I can imagine that we
> > a) Abbreviate the status i.e. (C)onfigured, (U)nconfigured (M)anaged
> > b) Drop the MAC address, because the Device name provides much more
> > informations on el7, than on el6
> > 
> > Looking at the output of nmcli, I'd choose b).
> > The mac address can still be viewed in the details dialog, it will just
> > vanish from the overview.
> > 
> > Thoughts?
> 
> Fabian, rhevh 6.6 with node 3.1 is still for RHEV 3.5 GA, so if you move the
> MAC, it is not good display for el6.

Good point. We migth just then want to distinguish between systemd and non-systemd systems. (Where we assume that systemd provides the predictive nic names).

Comment 8 Fabian Deutsch 2015-05-27 14:46:55 UTC
No customer case attached and this can wait for 3.6.

Comment 10 wanghui 2015-10-28 09:09:23 UTC
Test version:
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7-7.2-20151025.0.el7ev
2. Check the NIC name in Network page.

Test result:
1. The NIC name can be showed as whole name. And as comment#2 shows, it remove MAC address info in ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch.


This issue is fixed in ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch. Change the status to verified.

Comment 12 errata-xmlrpc 2016-03-09 14:13:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.