Bug 1128093 - [Dist-geo-rep] after restore of symlink snapshot in geo-rep setup, few files fail to sync to slave.
Summary: [Dist-geo-rep] after restore of symlink snapshot in geo-rep setup, few files ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1127234
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 09:47 UTC by Aravinda VK
Modified: 2015-05-14 17:35 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1127234
Environment:
Last Closed: 2015-05-14 17:26:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-08-08 11:35:48 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2014-08-08 11:40:26 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Anand Avati 2014-08-08 11:42:28 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Anand Avati 2014-08-08 11:45:45 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Anand Avati 2014-08-08 11:46:11 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 6 Anand Avati 2014-08-12 11:55:46 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#6) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 7 Anand Avati 2014-08-14 08:44:17 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#7) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 8 Anand Avati 2014-08-16 14:38:15 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#8) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 9 Anand Avati 2014-08-19 09:23:12 UTC
REVIEW: http://review.gluster.org/8439 (geo-rep: Fixing issue with xsync upper limit) posted (#9) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 10 Anand Avati 2014-08-20 06:27:33 UTC
COMMIT: http://review.gluster.org/8439 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit d0a3b4307e40b70d73faf4baed9fa0c930682894
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Aug 8 15:06:11 2014 +0530

    geo-rep: Fixing issue with xsync upper limit
    
    While identifying the file/dir to sync, xtime of the file was compared
    with xsync_upper_limit as `xtime < xsync_upper_limit` After the sync,
    xtime of parent directory is updated as stime. With the upper limit
    condition, stime is updated as MIN(xtime_parent, xsync_upper_limit)
    
    With this files will get missed if `xtime_of_file == xsync_upper_limit`
    
    With this patch xtime_of_file is compared as
    xtime_of_file <= xsync_upper_limit
    
    BUG: 1128093
    Change-Id: I5022ce67ba503ed4621531a649a16fc06b2229d9
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/8439
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 11 Anand Avati 2014-08-22 12:20:16 UTC
REVIEW: http://review.gluster.org/8517 (features/changelog: barrier all entry creation fops) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 12 Anand Avati 2014-08-25 10:32:26 UTC
REVIEW: http://review.gluster.org/8533 (features/changelog: Crash consistency of changelog wrt snapshot) posted (#1) for review on master by ajeet jha (ajha@redhat.com)

Comment 13 Anand Avati 2014-08-25 11:59:55 UTC
REVIEW: http://review.gluster.org/8533 (features/changelog: Crash consistency of changelog wrt snapshot) posted (#2) for review on master by ajeet jha (ajha@redhat.com)

Comment 14 Anand Avati 2014-08-25 15:37:12 UTC
COMMIT: http://review.gluster.org/8517 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 11beb72ef0ec80d13dcfe7061b46cad105f6e77e
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Fri Aug 22 17:15:13 2014 +0530

    features/changelog: barrier all entry creation fops
    
    when a snapshot is taken, there are chances of entry creation fops
    not being recorded either in changelog or through the recursive
    ancestry xtime updation by marker. This causes consumers of changelog
    (primarily geo-replication as of today) to not be aware of these entries
    after a snapshot is restored. This can lead to inconsistencies. This patch
    is an interim workaround to barrier creates till changelog becomes completely
    crash consistent.
    
    BUG: 1128093
    Change-Id: Ie0dbfd74beecb88df5c2ddf9fc680af91547c3f3
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/8517
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: ajeet jha <ajha@redhat.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 15 Anand Avati 2014-08-25 16:45:17 UTC
REVIEW: http://review.gluster.org/8533 (features/changelog: Crash consistency of changelog wrt snapshot) posted (#3) for review on master by ajeet jha (ajha@redhat.com)

Comment 16 Anand Avati 2014-08-25 17:07:26 UTC
REVIEW: http://review.gluster.org/8533 (features/changelog: Crash consistency of changelog wrt snapshot) posted (#4) for review on master by ajeet jha (ajha@redhat.com)

Comment 17 Anand Avati 2014-08-26 00:40:37 UTC
REVIEW: http://review.gluster.org/8533 (features/changelog: Crash consistency of changelog wrt snapshot) posted (#5) for review on master by ajeet jha (ajha@redhat.com)

Comment 18 Anand Avati 2014-08-26 09:13:36 UTC
REVIEW: http://review.gluster.org/8542 (features/changelog: Removal of redundant fop color count while draining.) posted (#1) for review on master by ajeet jha (ajha@redhat.com)

Comment 19 Anand Avati 2014-08-26 10:16:56 UTC
COMMIT: http://review.gluster.org/8533 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit acabde2c297c4175946565017ba17a251ad3fb1c
Author: Ajeet Jha <ajha@redhat.com>
Date:   Sat Aug 23 19:06:45 2014 +0530

    features/changelog: Crash consistency of changelog wrt snapshot
    
    This patch introduces call-path fop details logging for data operations
    in CHANGELOG.SNAP. This feature is enabled with barrier-enable
    notification and disabled with barrier-disable notification.
    
    Change-Id: Ib548d34203eb99cea478a6baff402e82251c73a4
    BUG: 1128093
    Signed-off-by: Ajeet Jha <ajha@redhat.com>
    Reviewed-on: http://review.gluster.org/8533
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 20 Anand Avati 2014-08-26 11:55:48 UTC
COMMIT: http://review.gluster.org/8542 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 27daeba0f7e02669919a7d89a04ea8fe39e06898
Author: Ajeet Jha <ajha@redhat.com>
Date:   Tue Aug 26 14:39:24 2014 +0530

    features/changelog: Removal of redundant fop color count while draining.
    
    Change-Id: Ie5581579df63513e636fa3dd92dd90699ea7d999
    BUG: 1128093
    Signed-off-by: Ajeet Jha <ajha@redhat.com>
    Reviewed-on: http://review.gluster.org/8542
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 21 Niels de Vos 2015-05-14 17:26:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 22 Niels de Vos 2015-05-14 17:28:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 23 Niels de Vos 2015-05-14 17:35:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.