Bug 1128096 - copr: list ignatenkobrain doesn't work (TypeError: must be unicode, not str)
Summary: copr: list ignatenkobrain doesn't work (TypeError: must be unicode, not str)
Keywords:
Status: CLOSED DUPLICATE of bug 1123886
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 09:50 UTC by Igor Gnatenko
Modified: 2014-08-08 09:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 09:54:01 UTC


Attachments (Terms of Use)

Description Igor Gnatenko 2014-08-08 09:50:46 UTC
$ sudo dnf copr list ignatenkobrain
========================================================================= List of ignatenkobrain coprs =========================================================================
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1053, in run
    return self.command.run(self.base.extcmds)
  File "/home/brain/Documents/git/upstream/dnf-plugins-core/plugins/copr.py", line 138, in run
    msg = self.base.output.fmtKeyValFill(msg, desc)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 703, in fmtKeyValFill
    keylen = exact_width(key)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 164, in exact_width
    return sum(_exact_width_char(c) for c in msg)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 164, in <genexpr>
    return sum(_exact_width_char(c) for c in msg)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 138, in _exact_width_char
    return 2 if unicodedata.east_asian_width(uchar) in ('W', 'F', 'A') else 1
TypeError: must be unicode, not str

Comment 1 Miroslav Suchý 2014-08-08 09:54:01 UTC

*** This bug has been marked as a duplicate of bug 1123886 ***


Note You need to log in before you can comment on or make changes to this bug.