Bug 1128130 - Libgcrypt is vulnerable to side-channel attack on ELGAMAL sub-keys
Summary: Libgcrypt is vulnerable to side-channel attack on ELGAMAL sub-keys
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: libgcrypt
Version: 20
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: fst_owner=bvincent, fst_ping=1
Depends On:
Blocks: CVE-2014-5270
TreeView+ depends on / blocked
 
Reported: 2014-08-08 11:02 UTC by Tristan Santore
Modified: 2015-06-29 21:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 21:58:42 UTC


Attachments (Terms of Use)

Description Tristan Santore 2014-08-08 11:02:15 UTC
Description of problem:
libgcrypt 1.5.3 is vulnerable to a side-channel ELGAMAL sub-key attack.

Version-Release number of selected component (if applicable):
libgcrypt 1.5.3

Additional info:
Werner has just informed us that the combination of gnupg2 and libgrypt <1.5.4 is vulnerable to the mentioned attack.

Comment 1 Murray McAllister 2014-08-11 04:28:51 UTC
Hi Tristan, thank you for the heads up and filing this bug!

I filed a 'top level' bug to track this issue across all other places it is shipped, bug 1128531

Comment 2 pjp 2015-04-09 17:33:22 UTC
Hello tmraz@redhat.com,

You plan to fix this soon?

Comment 3 Tomas Mraz 2015-04-10 07:44:09 UTC
No, I do not plan to fix this for Fedora 20.

Comment 4 Fedora End Of Life 2015-05-29 12:35:10 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2015-06-29 21:58:42 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.