Bug 1128135 - [RFE] provide api for easy printing tables
Summary: [RFE] provide api for easy printing tables
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks: 1123886
TreeView+ depends on / blocked
 
Reported: 2014-08-08 11:26 UTC by Igor Gnatenko
Modified: 2017-06-25 17:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-25 17:59:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Gnatenko 2014-08-08 11:26:59 UTC
I have used output.fmtKeyValue for copr plugin, but now it doesn't work.

https://github.com/akozumpl/dnf-plugins-core/blob/master/plugins/copr.py#L138

Comment 1 Honza Silhan 2014-08-11 12:11:57 UTC
Hi, Ales must decide what should go to API. I see 3 options:
* make it API
* copy it to pluginscore module - this function is too complex and long so I would not recommend that.
* use it at own risk, just make sure that any string you pass into it is unicode

AFAIK copr is the only plugin now that uses it. I would suggest go with choice 3 and when another plugin will need it, add it to dnf API.

Comment 2 Tim Lauridsen 2014-08-11 13:07:37 UTC
Another option is for a plugin to handle it's own text output.

The output module is part of the dnf cli, not the dnf backend api and plugins should not use that IMO.

Comment 3 Ales Kozumplik 2014-08-12 05:35:16 UTC
We probably should provide some output API so the results are unified across plugins.

Comment 4 Fedora Admin XMLRPC Client 2016-07-08 09:25:40 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Jaroslav Mracek 2017-06-25 17:59:04 UTC
I think it doesn't have much sense to keep opened the bug report, because propose of the new API should be handled by pull request with explanation why it has to be approved. This is also mentioned as option in the firs point (make it API) of Comment 1.

Hope that you understand that.


Note You need to log in before you can comment on or make changes to this bug.