Bug 1128139 - dnf install succeeds with a non-installable package
Summary: dnf install succeeds with a non-installable package
Keywords:
Status: CLOSED DUPLICATE of bug 1107737
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 11:51 UTC by Nikolai Kondrashov
Modified: 2014-11-19 12:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 12:29:45 UTC


Attachments (Terms of Use)

Description Nikolai Kondrashov 2014-08-08 11:51:20 UTC
Description of problem:
"dnf install" returns successful exit code despite one of the supplied packages being not installable, i.e. missing from the repos.

Version-Release number of selected component (if applicable):
dnf-0.5.4-1.fc20.noarch

How reproducible:
always

Steps to Reproduce:
Execute "dnf install missing bash"

Actual results:
Returned exit code is zero.

Expected results:
Returned exit code is non-zero

Additional info:
"dnf install missing" returns non-zero

Comment 1 Honza Silhan 2014-08-08 11:54:59 UTC
Thanks for the report. We'll take a look.

Comment 2 Honza Silhan 2014-11-19 12:29:45 UTC

*** This bug has been marked as a duplicate of bug 1107737 ***


Note You need to log in before you can comment on or make changes to this bug.