Bug 1128146 - PEERDNS set to YES for Neutron Networker nodes
Summary: PEERDNS set to YES for Neutron Networker nodes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Installer
Assignee: Lars Kellogg-Stedman
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 12:04 UTC by Balaji
Modified: 2014-09-08 19:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-08 19:37:15 UTC


Attachments (Terms of Use)

Description Balaji 2014-08-08 12:04:33 UTC
Description of problem:
PEERDNS is set to YES as against NO for Neutron Networker node during Neutron Deployment. 

Version-Release number of selected component (if applicable):


How reproducible:
During Neutron Deployment puppet will not talk to master since /etc/resolv.conf gets overwritten due to Peerdns setting to yes on public network. This is in an environment where public interface has DHCP as well. Controller and compute nodes are set Peerdns=no and behave correctly. 

Steps to Reproduce:
1.Deploy non HA neutron with private and public interface (where public has dhcp as well)
2.
3.

Actual results:
Deployment hangs at 60% for neutron networker since /etc/resolv.conf gets overwritten and puppet client cannot reach puppet master.

Expected results:
/etc/resolv.conf should point to provisioning network name server by setting all non provisioning interfaces to peerdns=no.

Additional info:

Comment 2 Mike Burns 2014-08-08 12:28:18 UTC
Lars,

Thoughts here?

Comment 4 Lars Kellogg-Stedman 2014-08-08 14:57:13 UTC
I don't think there's a graceful solution for this right now.

In an environment with multiple DHCP servers providing DNS information (in this case, the foreman server and the DCHP server on the external network), you need to use the PEERDNS setting to prevent your resolv.conf from oscillating between information from the two servers.

In our current release, we have settled on using the Foreman host as the default source of DNS information, because this has been most generally useful for testing environments and simple PoC setups.

The way to fix this right now is to edit the %post section of the kickstart to set the PEERDNS flags appropriately for your local environment (by going to Hosts -> Provisioning Templates, selecting the "Kickstart RHEL default" template, looking for the code that sets PEERDNS, and adding your own changes after that point).

Comment 5 Lars Kellogg-Stedman 2014-09-08 19:37:15 UTC
This should be addressed by the installer changes to handle network configuration.


Note You need to log in before you can comment on or make changes to this bug.