Bug 1128147 - please split vpnc-script from vpnc
Summary: please split vpnc-script from vpnc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vpnc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Schwarz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1148049
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 12:14 UTC by Nikos Mavrogiannopoulos
Modified: 2014-11-10 09:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-10 09:15:46 UTC


Attachments (Terms of Use)
proposed spec.patch for rawhide (22.64 KB, patch)
2014-11-06 10:47 UTC, Felix Schwarz
no flags Details | Diff

Description Nikos Mavrogiannopoulos 2014-08-08 12:14:00 UTC
Currently vpnc-script is generated by the vpnc package and is used except from vpnc by the openconnect package. 

The issue is that porting openconnect to epel7 or other branches will require porting vpnc, which is really orthogonal to the original port. For that vpnc-script should no longer be shipped by vpnc and should be a separate package allowing the port of openconnect to other branches without depending on the port of vpnc.

Comment 1 Nikos Mavrogiannopoulos 2014-09-03 08:06:45 UTC
Any update on that issue? Note, that I am offering to do that work; if I don't receive a reply I will start the unresponsive maintainer process.

Comment 2 Christian Krause 2014-09-30 15:00:57 UTC
If I understand correctly, your suggestion is to create a separate package (not only sub-package) just for the vpnc-script?

So the next steps would be:
- submit a new package request for Fedora

once that's approved:
- remove the vpnc-script from vpnc
- deprecate / obsolete vpnc-script sub-package (but make sure, that all upgrade-paths work properly)

Are you going to submit the new package? ;-)

Comment 3 Nikos Mavrogiannopoulos 2014-09-30 15:07:58 UTC
Hello Christian,
 Indeed that's the plan; I needed you though to remove vpnc-script from vpnc once the new package is in place. I'm starting the process then.

Comment 4 Felix Schwarz 2014-11-02 22:17:08 UTC
If I understood the plan correctly, the next step is to remove vpnc-script from the vpnc package now that the new package got approved. I'm a bit puzzled because this bug is closed but I still see the subpackage in Fedora git.

Comment 5 Nikos Mavrogiannopoulos 2014-11-03 07:48:32 UTC
(In reply to Felix Schwarz from comment #4)
> If I understood the plan correctly, the next step is to remove vpnc-script
> from the vpnc package now that the new package got approved. I'm a bit
> puzzled because this bug is closed but I still see the subpackage in Fedora
> git.

That seems right, I didn't notice that vpnc-script remains in vpnc's master. Reopening.

What needs to be done?
Remove vpnc-script from vpnc's master branch.

Comment 6 Felix Schwarz 2014-11-03 08:17:01 UTC
+ ensuring the upgrade path works (though "vpnc-script-20140805.1.df5808b" should replace "vpnc-script-0.5.3-23")

@Christian: Please also check my application for vpnc co-maintainership.

Comment 7 Nikos Mavrogiannopoulos 2014-11-04 07:16:50 UTC
(In reply to Felix Schwarz from comment #6)
> + ensuring the upgrade path works (though "vpnc-script-20140805.1.df5808b"
> should replace "vpnc-script-0.5.3-23")

That is not needed. 20140805.1.df5808b > 0.5.3-23 according to rpmdev-vercmp.

Comment 8 Felix Schwarz 2014-11-06 10:47:16 UTC
Created attachment 954392 [details]
proposed spec.patch for rawhide

I attached my proposed changes so Christian can review it first. I tested the change by applying this patch to F20 (with some trivial conflict resolution) and I could see any difference when connecting to my VPN (so I guess that means it's working ;-).

@chkr: This patch is meant to be applied after the patch for bug 1016215.

@nmav: Currently the vpnc-package has only a rawhide branch. Do you intend to create a branch for f21?

Comment 9 Nikos Mavrogiannopoulos 2014-11-06 10:52:38 UTC
(In reply to Felix Schwarz from comment #8)

> @chkr: This patch is meant to be applied after the patch for bug 1016215.
> 
> @nmav: Currently the vpnc-package has only a rawhide branch. Do you intend
> to create a branch for f21?

I'd suggest to make not change in F21 as it is already out, and finalize the transition in F22.

Comment 10 Felix Schwarz 2014-11-06 19:34:11 UTC
(In reply to Nikos Mavrogiannopoulos from comment #9)
> I'd suggest to make not change in F21 as it is already out, and finalize the
> transition in F22.

That's what I assumed as well but I wanted to be sure :-)

Comment 11 Christian Krause 2014-11-09 23:59:36 UTC
I've reviewed the patch: besides the %changelog section (wrong NVR) it is OK.

Comment 12 Felix Schwarz 2014-11-10 09:15:46 UTC
Fixed in current vpnc git. I suspect this will cause a bit of unexpected behavior in a lot of fedora tools which assume that a rpm name always belongs to a single package (e.g. https://apps.fedoraproject.org/packages/...) but that's another story.

Nikos: I'll cc you on a few of vpnc-script related bug reports (currently filed for vpnc but sometimes they actually refer to vpnc-script) over the next week or so. Hope that's ok.


Note You need to log in before you can comment on or make changes to this bug.