Bug 1128151 - Error while upgrading from JON 3.1.2 to 3.3: [rhq.autoinstall.server.admin.password] must exist and be set to a valid string value
Summary: Error while upgrading from JON 3.1.2 to 3.3: [rhq.autoinstall.server.admin.pa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: Jay Shaughnessy
QA Contact: Filip Brychta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 12:44 UTC by Matt Mahoney
Modified: 2014-12-11 14:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:02:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt Mahoney 2014-08-08 12:44:35 UTC
Description of problem:
The following error occurred while upgrading from JON 3.2.1 to JON 3.3

08:28:00,012 ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now exit due to previous errors: java.lang.Exception: Validation errors:
[rhq.autoinstall.server.admin.password] must exist and be set to a valid string value

    at org.rhq.enterprise.server.installer.ServerProperties.validate(ServerProperties.java:332) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.ServerProperties.validate(ServerProperties.java:270) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.InstallerServiceImpl.test(InstallerServiceImpl.java:149) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:92) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.Installer.main(Installer.java:59) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]


Version-Release number of selected component (if applicable):

JON 3.1.2 upgrade to JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1.Install an instance of JON 3.1.2 
2.Perform an upgrade of JON 3.1.2 to JON 3.3
3.

Actual results:
Error indicating password not existing during upgrade.

Expected results:
No error should occur - non-existing password should be handled properly.

Additional info:

Comment 1 Filip Brychta 2014-08-11 09:42:41 UTC
Setting severity to high as it will affect all upgrades.
This required property (rhq.autoinstall.server.admin.password) is irrelevant for upgrades, because a password for rhqadmin had been set in previous JON version. It should not be required during upgrade process at all.

Comment 4 Jay Shaughnessy 2014-09-15 15:31:28 UTC
master commit d83319b26276e4e24b197252dfecc4127311a0e2
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Mon Sep 15 11:28:05 2014 -0400

 Ensure that the property gets a string value assigned during upgrade so that
 the properties file passes validation. The dummy value is "ignored-on-upgrade",
 the rhqadmin user will already exist in an upgraded server's DB.


release/jon3.3.x commit 500a752d2f660d04e3c7e867041898559553e2e7
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Mon Sep 15 11:28:05 2014 -0400

    (cherry picked from commit d83319b26276e4e24b197252dfecc4127311a0e2)
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 5 Simeon Pinder 2014-10-01 21:33:41 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959

Comment 6 Filip Brychta 2014-10-02 08:38:28 UTC
Verified on
Version :	
3.3.0.ER04
Build Number :	
99d2107:d7c537e


Note You need to log in before you can comment on or make changes to this bug.