Bug 1128159 - [eap6] Host controller resource is down when there is no name attribute in host element in host.xml
Summary: [eap6] Host controller resource is down when there is no name attribute in ho...
Keywords:
Status: CLOSED DUPLICATE of bug 1128141
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 12:57 UTC by Filip Brychta
Modified: 2014-08-08 14:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 14:34:09 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1080552 None None None Never

Internal Links: 1080552

Description Filip Brychta 2014-08-08 12:57:25 UTC
Description of problem:
$Summary

Version-Release number of selected component (if applicable):
Version :	
3.3.0.DR01
Build Number :	
6468454:dda0a47

How reproducible:
Always

Steps to Reproduce:
1. unzip eap6
2. edit domain/configuration/host.xml, delete the name attribute in the host root element
3. start it (./domain.sh &)
4. run discovery scan (if necessary)
5. import the eap6 from discovery queue
6. navigate to the eap6 resource and install a management user (Operations->New->Install a management user)


Actual results:
The eap6 resource is still down and follwing errors are visible in agent.log:

2014-08-08 08:53:24,343 ERROR [ResourceContainer.invoker.daemon-47] (rhq.modules.plugins.jbossas7.BaseServerComponent)- Failed to read attribute [domain-config-file]: java.lang.ArrayIndexOutOfBoundsException
java.lang.ArrayIndexOutOfBoundsException
2014-08-08 08:53:24,343 ERROR [ResourceContainer.invoker.daemon-47] (rhq.modules.plugins.jbossas7.BaseServerComponent)- Failed to read attribute [host-config-file]: java.lang.ArrayIndexOutOfBoundsException
java.lang.ArrayIndexOutOfBoundsException
2014-08-08 08:53:24,343 ERROR [ResourceContainer.invoker.daemon-47] (rhq.modules.plugins.jbossas7.BaseServerComponent)- Failed to read attribute [domain-temp-dir]: java.lang.ArrayIndexOutOfBoundsException
java.lang.ArrayIndexOutOfBoundsException
2014-08-08 08:53:24,344 WARN  [MeasurementManager.collector-1] (rhq.core.pc.measurement.MeasurementCollectorRunner)- Failure to collect measurement data for Resource[id=14445, uuid=7554accb-a6aa-4ed5-90fa-670dc2078aed, type={JBossAS7}JBossAS7 Host Controller, key=hostConfig: /home/hudson/jboss-eap6-domain/domain/configuration/host.xml, name=EAP Domain Controller (127.0.0.1:9990), parent=fbr-jon33-eap6.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.2.4.GA] - cause: java.lang.ArrayIndexOutOfBoundsException:null


Expected results:
The eap6 resource is up

Comment 1 Libor Zoubek 2014-08-08 14:34:09 UTC

*** This bug has been marked as a duplicate of bug 1128141 ***


Note You need to log in before you can comment on or make changes to this bug.