Bug 1128160 - check free space before download
Summary: check free space before download
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-upgrade-tool
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.7
Assignee: Michal Bocek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 12:58 UTC by pstodulk
Modified: 2019-07-01 15:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-01 15:26:24 UTC


Attachments (Terms of Use)

Description pstodulk 2014-08-08 12:58:45 UTC
Description of problem:
redhat-upgrade-tool doesn't check available space for new packages before download. I think it should be checked when downloaded packages are nown.


Version-Release number of selected component (if applicable):
RHEL-6.5

How reproducible:
always

Steps to Reproduce:
1. fill sufficiently free space by some file
2. redhat-upgrade-tool --network 7.0 --instrepo \
   http://download.eng.brq.redhat.com/released/RHEL-7/7.0/Server/x86_64/os/

Actual results:
[....]
Downloading failed: Errors were encountered while downloading packages.
  2:texlive-pst-node-svn27799.1.25-32.el7.noarch: Insufficient space in download directory /var/tmp/system-upgrade/cmdline-instrepo/packages
    * free   0 
    * needed 39 k
[...]

Expected results:
Insufficiency free space for download ....

Comment 1 pstodulk 2014-08-08 13:12:09 UTC
Version-Release number of component:
redhat-upgrade-tool-0.7.24-1.el6.noarch

Comment 2 David Shea 2015-10-30 20:07:31 UTC
*** Bug 1276577 has been marked as a duplicate of this bug. ***

Comment 4 Michal Bocek 2019-07-01 15:26:24 UTC
Closing this bugzilla as the component is under a maintenance mode in which the maintainers are going to fix only critical bugs. If you consider the bugzilla critical, feel free to reopen the bug with an explanation.


Note You need to log in before you can comment on or make changes to this bug.