Bug 1128187 - Display valid error message when I try to reimport the same manifest in same org
Summary: Display valid error message when I try to reimport the same manifest in same org
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 14:10 UTC by sthirugn@redhat.com
Modified: 2019-09-26 13:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:10:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error message while uploading the same manifest (144.18 KB, image/png)
2014-08-08 14:11 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Red Hat Bugzilla 1096302 'unspecified' 'CLOSED' 'Unable to upload manifest' 2019-11-25 14:47:54 UTC

Internal Links: 1096302

Description sthirugn@redhat.com 2014-08-08 14:10:32 UTC
Description of problem:
Display valid error message when I try to reimport the same manifest in same org

Version-Release number of selected component (if applicable):
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create an ORG
2. Upload a manifest A
3. Without changing anything in the manifest, reupload the same manifest A

Actual results:
"Error Importing manifest." (see screenshot)

But the Import History shows me " Import is the same as existing data " (see screenshot)

Expected results:
Display proper error message to the user something like "Import is the same as existing data" instead of "Error importing manifest"

Additional info:

Comment 1 sthirugn@redhat.com 2014-08-08 14:11:39 UTC
Created attachment 925187 [details]
Error message while uploading the same manifest

Comment 3 Brad Buckingham 2015-08-27 20:06:14 UTC
I have tested this on a Satellite 6.1.1 GA install and am no longer observing the behavior observed.

RPMs:
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
foreman-1.7.2.34-1.el7sat.noarch

Repeated attempts to 'Refresh Manifest' now show the following in the UI:

Notification:
 Manifest successfully refreshed. 

Manifest History:
 Default_Organization file imported successfully.

Comment 4 sthirugn@redhat.com 2016-03-18 19:02:29 UTC
The original scenario mentioned in the bug is not worth fixing as the user is required to delete the existing manifest to upload a new manifest.

As mentioned in Comment 3, Refresh manifest works fine in Satellite 6.2.0-beta-snap4

Comment 7 errata-xmlrpc 2016-07-27 09:10:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.