Bug 1128202 - /usr/lib/systemd/fedora-readonly has poor indenting
Summary: /usr/lib/systemd/fedora-readonly has poor indenting
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukáš Nykrýn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 14:48 UTC by John Florian
Modified: 2014-08-08 14:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 14:59:57 UTC


Attachments (Terms of Use)
indentation patch (11.28 KB, patch)
2014-08-08 14:48 UTC, John Florian
no flags Details | Diff

Description John Florian 2014-08-08 14:48:43 UTC
Created attachment 925193 [details]
indentation patch

Description of problem:
I'm unaware of any formal documentation for the stateless support in Fedora and thus must resort to reading the shell script to understand the behavior and how I can use it.  Unfortunately this task is made difficult by the poor indenting within /usr/lib/systemd/fedora-readonly.

I'm attaching a patch here that only alters the leading whitespace in this script so that indentation is correct and consistent throughout.  I hope this can be applied so that future readers may also benefit.  This should apply cleanly initscripts-9.51.

Comment 1 Lukáš Nykrýn 2014-08-08 14:59:57 UTC
Yes I agree that indentation in initscripts is really terrible. I thought fixing it in the past, but the problem is that it will make work with git history (git blame) more complicated.

So I am really sorry but I will not apply your patch.

And by the way I hope that we will drop this script in near future and use http://0pointer.de/blog/projects/stateless.html


Note You need to log in before you can comment on or make changes to this bug.