Bug 1128235 - node deactivate does not remove the binding of the repo to the node
Summary: node deactivate does not remove the binding of the repo to the node
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: nodes
Version: 2.4 Beta
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 16:19 UTC by Preethi Thomas
Modified: 2015-02-28 22:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:15:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 486 None None None Never

Description Preethi Thomas 2014-08-08 16:19:04 UTC
Description of problem:

If you deactivate a repo  that has has bound repo, seems like  node deactivate does not remove the binding. So if you activate it again the repo stays bound. So node sync, syncs up the repo.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
[root@cloud-qe-15 ~]# pulp-admin node deactivate --node-id node1
Child node deactivated.

[root@cloud-qe-15 ~]# 
[root@cloud-qe-15 ~]# 
[root@cloud-qe-15 ~]# pulp-admin node activate --node-id node1
Command: activate
Description: activate a consumer as a child node

Available Arguments:

  --consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                  allowed
  --strategy    - synchronization strategy (mirror|additive) default is additive
The following options were specified but do not exist on the command:
  --node-id
[root@cloud-qe-15 ~]# pulp-admin node activate --consumer-id node1
Consumer activated as child node.

[root@cloud-qe-15 ~]# pulp-admin node sync run --node-id node1
This command may be exited via ctrl+c without affecting the request.




(1/2) Repository: copy
[==================================================] 100%


(2/2) Repository: upload
[==================================================] 100%




Synchronization succeeded

+----------------------------------------------------------------------+
                       Child Node Synchronization
+----------------------------------------------------------------------+

Repository: 
  Action:          Merged
  Content Sources: 
    Downloads:     
    Total Passes:  0
    Total Sources: 0
  Id:              copy
  Units:           
    Added:   0
    Removed: 0
    Updated: 0

Repository: 
  Action:          Merged
  Content Sources: 
    Downloads:     
    Total Passes:  0
    Total Sources: 0
  Id:              upload
  Units:           
    Added:   0
    Removed: 0
    Updated: 0

Repository: 
  Action:          Removed
  Content Sources: 
    Downloads: 
  Id:              zoo
  Units:           
    Added:   0
    Removed: 0
    Updated: 0


Actual results:


Expected results:


Additional info:

Comment 1 Jeff Ortel 2014-08-18 18:02:46 UTC
Given that nodes are activated by adding a special note on the consumer document, I don't believe this is a regression.  Further, since the deactivation is a consumer update to the REST and manager layers, this would be hard to fix without doing a real hack.  There have been discussion about making nodes a 1st class thing in the platform.  I think this should be addressed properly then.

Comment 2 Brian Bouterse 2015-02-28 22:15:02 UTC
Moved to https://pulp.plan.io/issues/486


Note You need to log in before you can comment on or make changes to this bug.