Bug 1128245 - WebUI suggested subscription-manager registration command does not work
Summary: WebUI suggested subscription-manager registration command does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1161758 1169474 1172227 1172936 1188146 (view as bug list)
Depends On:
Blocks: 1139277
TreeView+ depends on / blocked
 
Reported: 2014-08-08 16:50 UTC by Matej Kollar
Modified: 2019-05-20 11:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-20 18:32:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0247 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2015-02-20 23:30:44 UTC
Red Hat Knowledge Base (Solution) 1305193 None None None Never

Description Matej Kollar 2014-08-08 16:50:10 UTC
Description of problem: WebUI for 
example.com/activation_keys/:id/info
suggest using

  subscription-manager register --org="<org_name>" --activationkey="<activation_key>"

instead of

  subscription-manager register --org="<org_label>" --activationkey="<activation_key>"


Version-Release number of selected component (if applicable):
sat6-Satellite-6.0.4-RHEL-6-20140730.0-Satellite-x86_64-dvd1.iso

How reproducible: always/deteminitic


Steps to Reproduce:
  1. create organization with spaces in name
  2. create AK for this org
  3. observe suggested registration command

Actual results:

  use name (spaces)

Expected results:

  use label (underscores)

Additional info:

  It does not work with name instead of label...

Comment 1 RHEL Product and Program Management 2014-08-08 17:03:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Christine Fouant 2014-08-27 16:58:56 UTC
Created redmine issue http://projects.theforeman.org/issues/7278 from this bug

Comment 4 Bryan Kearney 2014-08-28 14:04:56 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7278 has been closed
-------------
Christine Fouant
Applied in changeset commit:katello|144b8ad4db94f649c5360fde95021ff9b6b0cdea.

Comment 5 Christine Fouant 2014-11-14 15:56:49 UTC
*** Bug 1161758 has been marked as a duplicate of this bug. ***

Comment 6 jcallaha 2014-11-21 21:59:07 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***

Version Tested:
RHEL66 / RHEL7

katello-2.1.0-1.201411061509gitb0b8f43.el7.noarch
katello-repos-2.1.1-1.el7.noarch
katello-installer-2.1.0-1.201411172212git9d6f424.el7.noarch
rubygem-hammer_cli_katello-0.0.6-1.201411202238git7fa4778.git.0.a5a9308.el7.noarch
ruby193-rubygem-katello-2.1.0-1.201411202218git791c8dd.el7.noarch
katello-server-ca-1.0-1.noarch
katello-certs-tools-2.0.1-1.el7.noarch
pulp-katello-0.3-3.el7.noarch
katello-default-ca-1.0-1.noarch
subscription-manager-1.1.23-1.el6.x86_64

Comment 7 Bryan Kearney 2014-12-04 19:59:44 UTC
*** Bug 1169474 has been marked as a duplicate of this bug. ***

Comment 8 Christine Fouant 2014-12-09 16:48:41 UTC
*** Bug 1172227 has been marked as a duplicate of this bug. ***

Comment 9 Bryan Kearney 2014-12-11 13:17:58 UTC
*** Bug 1172936 has been marked as a duplicate of this bug. ***

Comment 11 jcallaha 2014-12-12 20:29:43 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***

Version Tested:
RHEL66 / RHEL 7

katello-installer-2.1.0-1.201412071742git114a910.el6.noarch
pulp-katello-0.3-3.el6.noarch
katello-default-ca-1.0-1.noarch
katello-repos-2.1.1-1.el6.noarch
ruby193-rubygem-katello-2.1.0-1.201412101236git4521c2f.el6.noarch
katello-certs-tools-2.0.1-1.el6.noarch
katello-server-ca-1.0-1.noarch
rubygem-hammer_cli_katello-0.0.6-1.201412101306git7d5e313.git.0.44a4586.el6.noarch
katello-2.1.0-1.201411061509gitb0b8f43.el6.noarch
katello-ca-consumer-qe-foreman-rhel66.usersys.redhat.com-1.0-1.noarch

Comment 13 Bryan Kearney 2015-02-05 19:27:38 UTC
Moving back to POST for cherry picking into 6.0.z

Comment 16 Christine Fouant 2015-02-11 15:28:51 UTC
*** Bug 1188146 has been marked as a duplicate of this bug. ***

Comment 17 jaudet 2015-02-11 20:26:20 UTC
Verified against four Satellite 6.0.8 applications, two of which are running on RHEL 6.6 and the other two of which are running on RHEL 7.0. Here was my verification procedure:

1. Create an organization named "before & after".
2. Switch to that organization's context.
3. Create an activation key named "activation & key".

Here is the message advertised on each machine after the above steps:

    This activation key may be used during system registration. For example:
    subscription-manager register --org="before___after" --activationkey="activation & key"

Comment 19 errata-xmlrpc 2015-02-20 18:32:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:0247


Note You need to log in before you can comment on or make changes to this bug.