Bug 1128292 - kickstaring vm using pulp synced kickstart tree for rhel6 are failing
Summary: kickstaring vm using pulp synced kickstart tree for rhel6 are failing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: rpm-support
Version: 2.4 Beta
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.5.0
Assignee: Barnaby Court
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 19:53 UTC by Preethi Thomas
Modified: 2014-11-24 21:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-24 21:33:24 UTC


Attachments (Terms of Use)
screenshot (1.46 MB, image/png)
2014-08-08 19:53 UTC, Preethi Thomas
no flags Details

Description Preethi Thomas 2014-08-08 19:53:15 UTC
Created attachment 925294 [details]
screenshot

Description of problem:
vms that are kickstarted using the pulp synced kickstart tree repos from cdn are failing with kernel panic

Version-Release number of selected component (if applicable):

[root@qe-blade-08 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.30.beta.el6.noarch
[root@qe-blade-08 ~]# 

How reproducible:


Steps to Reproduce:
1.sync the kickstart tree from cdn for 6.5
2. try to kickstart a vm with the tree
3.

Actual results:
kernel panic

Expected results:


Additional info:

Comment 1 Barnaby Court 2014-08-10 18:56:27 UTC
The issue is that the default property is not being set properly on the component groups.  If no group is set as default then the graphical installer lets you progress without selecting any group.  In this case packages are missing.  However, If a group is selected, minimal install, basic server, etc., then the install completes and boots successfully.

Comment 2 Barnaby Court 2014-08-10 18:58:02 UTC
Editing pulp_rpm/plugins/pulp_rpm/plugins/distributors/yum/metadata/package.py:78

and adding the lines:
        ElementTree.SubElement(group_element, 'default').text = \
            str(group_unit.metadata['default']).lower()
will fix the problem

Comment 3 Barnaby Court 2014-08-11 14:09:59 UTC
PR: https://github.com/pulp/pulp_rpm/pull/540

Comment 4 Randy Barlow 2014-08-13 19:59:10 UTC
This was fixed in the 2.4.1-0.1.alpha build.

Comment 5 Preethi Thomas 2014-08-19 16:21:33 UTC
verified with 2.4.1
kickstarted rhel6 with the synced repo from cdn

Comment 6 Randy Barlow 2014-08-20 03:31:06 UTC
We are rebasing pulp-2.4.1, and so all of these bugs can no longer be considered VERIFIED. We will need to recheck them against the rebased build to make sure the cherry picking strategy did not introduce any regressions.

Comment 7 Chris Duryee 2014-09-30 13:52:29 UTC
build: 2.5.0-0.6.beta

Comment 8 Preethi Thomas 2014-10-09 15:45:10 UTC
verified
[root@cloud-qe-15 ~]# rpm -qa pulp-server
pulp-server-2.5.0-0.7.beta.el7.noarch
[root@cloud-qe-15 ~]# 

kickstarted rhel6 with the synced repo from cdn


Note You need to log in before you can comment on or make changes to this bug.