Bug 1128296 - Content sync should not silently hang/fail due do to possibly malformed proxy url
Summary: Content sync should not silently hang/fail due do to possibly malformed proxy...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.5
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-08-08 20:09 UTC by Corey Welton
Modified: 2019-08-15 03:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When synchronizing content, the User Interface fails to complete the synchronization process and hangs indefinitely, despite the pulp logs registering errors. This error was caused by an incomplete URL. All URL parameters must contain thefull address and requires the "http" or "https" protocol. Prevalidation checks have been implemented to check the proxy URL and provide an error message should the proxy URL fail to comply with the requirements.
Clone Of:
Environment:
Last Closed: 2015-01-16 21:07:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0054 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2015-01-17 02:04:45 UTC
Red Hat Bugzilla 1031001 None None None Never
Red Hat Knowledge Base (Solution) 1186483 None None None Never

Internal Links: 1031001

Description Corey Welton 2014-08-08 20:09:54 UTC
Description of problem:

I *think* this is what the issue is.

Doing an install and passing proxy host/port flags with a malformed proxy url (i.e., no 'http://'), attempts to sync never time out and never throw errors.  Pulp logs blow up all over the place, however.


Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140806.0

How reproducible:


Steps to Reproduce:
1.  perform a katello-install with flags akin to the following:
--katello-proxy-url myproxy.example.com --katello-proxy-port 3128  
(please note any lacking "http://" prefix)
2.  Attempt syncing RH and/or custom content
3.  Wait...and wait... and wait...
4.  View pulp logs

Actual results:

UI just sits forever, but pulp logs appear to tell us there's an error

Aug  8 15:09:42 beast pulp: pulp_rpm.plugins.importers.yum.sync:INFO: Downloading metadata from http://satellite6.lab.eng.rdu2.redhat.com/devel/candidate-trees/Satellite/Satellite-6.0.4-RHEL-6-20140806.0/compose/rhcommon/x86_64/os/.
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Unhandled Exception in Worker Thread [139847057159936]
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Traceback (most recent call last):
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 92, in worker
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     session = build_session(self.config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 294, in build_session
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     _add_proxy(session, config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 325, in _add_proxy
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     url = ':'.join((host, str(config.proxy_port)))
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: TypeError: sequence item 0: expected string, NoneType found
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Unhandled Exception in Worker Thread [139847046670080]
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Traceback (most recent call last):
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 92, in worker
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     session = build_session(self.config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 294, in build_session
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     _add_proxy(session, config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 325, in _add_proxy
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     url = ':'.join((host, str(config.proxy_port)))
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: TypeError: sequence item 0: expected string, NoneType found
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Unhandled Exception in Worker Thread [139847057159936]
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Traceback (most recent call last):
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 92, in worker
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     session = build_session(self.config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 294, in build_session
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     _add_proxy(session, config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 325, in _add_proxy
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     url = ':'.join((host, str(config.proxy_port)))
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: TypeError: sequence item 0: expected string, NoneType found
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Unhandled Exception in Worker Thread [139847046670080]
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Traceback (most recent call last):
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 92, in worker
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     session = build_session(self.config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 294, in build_session
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     _add_proxy(session, config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 325, in _add_proxy
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     url = ':'.join((host, str(config.proxy_port)))
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: TypeError: sequence item 0: expected string, NoneType found
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Unhandled Exception in Worker Thread [139847057159936]
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: Traceback (most recent call last):
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 92, in worker
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     session = build_session(self.config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 294, in build_session
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     _add_proxy(session, config)
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 325, in _add_proxy
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR:     url = ':'.join((host, str(config.proxy_port)))
Aug  8 15:09:42 beast pulp: nectar.downloaders.threaded:ERROR: TypeError: sequence item 0: expected string, NoneType found

Expected results:
* Pulp errors need to bubble up
* We need to time out appropriately
* Perhaps we should better handle/test proxy urls at install and/or during syncs or what have you?

Additional info:

Comment 2 Corey Welton 2014-08-08 20:54:05 UTC
TBH I am not sure if it is the installer or the workers themselves just hanging ... even a service restart seems to be sitting for a long time on workers.... presumably when sync tasks are still waiting in dynflow...

celery multi v3.1.11 (Cipater)
> Stopping nodes...
        > reserved_resource_worker-1@beast.idm.lab.bos.redhat.com: TERM -> 27359
        > reserved_resource_worker-3@beast.idm.lab.bos.redhat.com: TERM -> 27405
        > reserved_resource_worker-2@beast.idm.lab.bos.redhat.com: TERM -> 27382
        > reserved_resource_worker-0@beast.idm.lab.bos.redhat.com: TERM -> 27340
> Waiting for 4 nodes -> 27359, 27405, 27382, 27340...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Comment 5 Justin Sherrill 2014-10-14 19:31:44 UTC
Created redmine issue http://projects.theforeman.org/issues/7943 from this bug

Comment 6 Bryan Kearney 2014-10-17 00:03:34 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7943 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello-installer|873174fbc9e13d065c4502a75ebb320e8053a385.

Comment 9 Mike McCune 2014-12-11 17:24:32 UTC
temp move to MOD for ET

Comment 11 jcallaha 2015-01-09 16:37:17 UTC
*** QE verified for z-stream ***

New error message encountered when passing a malformed proxy URL:
--katello-proxy-url must be a full URI and only supports http or https (e.g. http://proxy.example.com)

Comment 13 errata-xmlrpc 2015-01-16 21:07:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:0054


Note You need to log in before you can comment on or make changes to this bug.