Bug 1128301 - openstack-heat-engine missing requires on m2crypto
Summary: openstack-heat-engine missing requires on m2crypto
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-heat
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ryan Brown
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 20:58 UTC by James Slagle
Modified: 2014-08-19 15:28 UTC (History)
3 users (show)

Fixed In Version: openstack-heat-2014.1.2-1.0.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-19 15:27:26 UTC


Attachments (Terms of Use)

Description James Slagle 2014-08-08 20:58:52 UTC
Description of problem:
openstack-heat-engine fails to start with:
2014-08-08 16:46:23.642 13478 CRITICAL heat [-] ImportError: No module named M2Crypto

Version-Release number of selected component (if applicable):
[root@localhost ~]# rpm -q openstack-heat-common openstack-heat-engine
openstack-heat-common-2014.1.1-2.5.fc21.noarch
openstack-heat-engine-2014.1.1-2.5.fc21.noarch


How reproducible:
Always


It looks like the Requires: m2crypto was removed from openstack-heat.spec in commit de61c848d1442b07a0e789d9d234c30efd14ccc4 in dist-git, yet it's still required.

Comment 1 Jeff Peeler 2014-08-08 21:50:33 UTC
This has been fixed in openstack-heat-2014.1.2-0.3.fc21, which is not yet available in RDO:

http://kojipkgs.fedoraproject.org/packages/openstack-heat/2014.1.2/0.3.fc21/

Comment 2 Jeff Peeler 2014-08-08 21:52:59 UTC
Assigning to Ryan as he is handling the 2014.1.2 rebase and will make sure it gets into RDO.

Comment 6 James Slagle 2014-08-12 14:30:51 UTC
August 28th? So, to be clear, we are saying that Heat in RDO is unuseable for ~ 3 weeks?

Comment 7 James Slagle 2014-08-12 14:32:04 UTC
Meaning, following these instructions http://openstack.redhat.com/Quickstart leaves you with a Heat that tracebacks on start up.

Comment 8 Jeff Peeler 2014-08-12 15:04:30 UTC
No no, it should be the end of this week.

Comment 9 Jeff Peeler 2014-08-19 15:27:26 UTC
The update was put into RDO on Aug 15.


Note You need to log in before you can comment on or make changes to this bug.