Bug 1128303 - packstack does not deploy multi-node swift setup
Summary: packstack does not deploy multi-node swift setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: All
OS: Linux
medium
medium
Target Milestone: z1
: 5.0 (RHEL 7)
Assignee: Martin Magr
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 21:10 UTC by John Trowbridge
Modified: 2018-12-06 17:42 UTC (History)
7 users (show)

Fixed In Version: openstack-packstack-2014.1.1-0.41.dev1251.el7ost
Doc Type: Bug Fix
Doc Text:
This Packstack update adds parameter validation for CONFIG_SWIFT_STORAGES, which accepts the same values and deprecates CONFIG_SWIFT_STORAGE_HOSTS. Values of CONFIG_SWIFT_STORAGES must be a comma-separated list of paths to devices, for example: /path/to/device
Clone Of:
Environment:
Last Closed: 2014-09-30 17:51:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1324 normal SHIPPED_LIVE openstack-packstack and openstack-puppet-modules bug fix advisory 2014-09-30 21:49:21 UTC
OpenStack gerrit 120344 None None None Never

Description John Trowbridge 2014-08-08 21:10:06 UTC
Description of problem:

In RHOS4, we could give a list of storage nodes to the packstack configuration option CONFIG_SWIFT_STORAGE_HOSTS. In RHOS5, the CONFIG_SWIFT_STORAGES option does not work in the same way.

Version-Release number of selected component (if applicable):

packstack Icehouse 2014.1.1dev1220

How reproducible:
Easy to reproduce

Steps to Reproduce:
1. Make 2 nodes to install via packstack (192.168.0.1,192.168.0.2)
2. Set CONFIG_SWIFT_STORAGES=192.168.0.1,192.168.0.2 in the answer-file
3. Install via packstack

Actual results:
swift services and loopback device on 192.168.0.1
no swift services or loopback on 192.168.0.2

Expected results:
swift services and loopback on all configured nodes.



Additional info:
Looking at packstack/plugins/swift_600.py this looks like it could be expected behavior. Does this mean this type of setup via packstack is no longer an option?

Comment 2 Martin Magr 2014-08-11 07:43:44 UTC
From RHOS-5+/RDO Icehouse it is no longer possible to install multi-host Swift. So this is not a bug. But be should add a validator on parameter CONFIG_SWIFT_STORAGES, which will fail packstack if invalid values (such as IP addresses) are passed. Valid values are paths which should Swift use as storages.

Comment 3 John Fulton 2014-08-11 18:24:52 UTC
Just a comment for clarification, based on my reading of the comments so far. 

* The goal of this bug report is not to get packstack installing multi-host Swift. That is not supported and that's why above it is referred to as not a bug". The status of this bug report is still "new" and "won't fix" for another reason. 

* The bug is that packstack should have printed an error that an IP cannot be set in CONFIG_SWIFT_STORAGES. The code already looks for IP:device pattern, the problem is that it just silently drops the IP. 

If I am misreading the comments to come to the above two conclusions incorrectly, then please clarify. Thanks. --John

Comment 8 errata-xmlrpc 2014-09-30 17:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1324.html


Note You need to log in before you can comment on or make changes to this bug.