Bug 1128315 - wine-1.7.22-4 notification area icon
Summary: wine-1.7.22-4 notification area icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 23:39 UTC by Davide Repetto
Modified: 2014-09-09 22:17 UTC (History)
4 users (show)

Fixed In Version: wine-1.7.25-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 22:12:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Wine HQ 37143 None None None Never

Description Davide Repetto 2014-08-08 23:39:25 UTC
Description of problem:
Just upgraded to wine-1.7.22-4.fc20.x86_64 and now icons of Windows programs are not properly displayed in the notification area (tested in mate and xfce). They do not appear at all (in xfce) or appear as an 1 pixel wide vertical line (in mate).

Version-Release number of selected component (if applicable):
wine-1.7.22-4.fc20.x86_64


How reproducible:
Always

Steps to Reproduce:
1. upgrade wine to wine-1.7.22-4
2. Run a windows program that display an icon in the notification area as for example eMule or Spotify

Actual results:
In the notification area you'll see no icon, but (in mate) you'll notice the appearance of a a 1px wide vertical line which is in no way selectable with the mouse.

Expected results:
Icon is displayed in the notification area and usable with the mouse 

Additional info:
I tested in a VM under XFCE and on my PC under MATE

Comment 1 Michael Cronenworth 2014-08-16 20:36:17 UTC
Could you try 1.7.24?

https://admin.fedoraproject.org/updates/wine-1.7.24-1.fc20

If the issue still exists can you open a report upstream? Link the new report here.

https://bugs.winehq.org/

Comment 2 Davide Repetto 2014-08-19 18:42:21 UTC
Yep. The problem persists with wine-1.7.24-1.fc20.

Reported Upstream as:
https://bugs.winehq.org/show_bug.cgi?id=37143

Comment 3 Davide Repetto 2014-08-25 12:54:05 UTC
The external bug was closed as "Not a wine bug."

Apparently the issue is due to "the wine-compholio patchset which was recently added to Fedora wine build".

> The issue was already fixed and should be resolved in the next
> wine-compholio release. For more information take a look at
> https://github.com/compholio/wine-compholio/issues/52

Comment 4 Fedora Update System 2014-08-25 13:35:52 UTC
wine-1.7.25-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wine-1.7.25-1.fc20

Comment 5 Fedora Update System 2014-08-27 01:37:00 UTC
Package wine-1.7.25-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.7.25-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9790/wine-1.7.25-1.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-08-27 04:48:51 UTC
wine-1.7.25-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wine-1.7.25-1.fc19

Comment 7 Fedora Update System 2014-09-09 22:12:25 UTC
wine-1.7.25-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-09-09 22:17:15 UTC
wine-1.7.25-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.