Bug 1128351 - SELinux is preventing /usr/lib/systemd/systemd-localed from 'search' accesses on the directory .
Summary: SELinux is preventing /usr/lib/systemd/systemd-localed from 'search' accesses...
Keywords:
Status: CLOSED DUPLICATE of bug 1081411
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:844de12c129aa408c723896e552...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 10:43 UTC by Moez Roy
Modified: 2014-09-03 14:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-03 14:43:11 UTC


Attachments (Terms of Use)

Description Moez Roy 2014-08-09 10:43:28 UTC
Description of problem:
SELinux is preventing /usr/lib/systemd/systemd-localed from 'search' accesses on the directory .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-localed should be allowed search access on the  directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-localed /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_localed_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                 [ dir ]
Source                        systemd-localed
Source Path                   /usr/lib/systemd/systemd-localed
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-215-9.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.15.7-200.fc20.x86_64 #1 SMP Mon
                              Jul 28 18:50:26 UTC 2014 x86_64 x86_64
Alert Count                   3
First Seen                    2014-08-06 22:13:27 PDT
Last Seen                     2014-08-08 23:08:57 PDT
Local ID                      e39237ea-df48-4425-b7db-0bc07374215a

Raw Audit Messages
type=AVC msg=audit(1407564537.695:355): avc:  denied  { search } for  pid=1105 comm="systemd-localed" name="/" dev="tmpfs" ino=19090 scontext=system_u:system_r:systemd_localed_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=dir


type=SYSCALL msg=audit(1407564537.695:355): arch=x86_64 syscall=open success=no exit=EACCES a0=7f4c120a7cad a1=80100 a2=0 a3=0 items=0 ppid=1 pid=1105 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-localed exe=/usr/lib/systemd/systemd-localed subj=system_u:system_r:systemd_localed_t:s0 key=(null)

Hash: systemd-localed,systemd_localed_t,tmpfs_t,dir,search

Version-Release number of selected component:
selinux-policy-3.12.1-179.fc20.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-1.fc21.x86_64
type:           libreport

Potential duplicate: bug 1081411

Comment 1 Miroslav Grepl 2014-09-03 14:43:11 UTC

*** This bug has been marked as a duplicate of bug 1081411 ***


Note You need to log in before you can comment on or make changes to this bug.