Bug 1128353 - Xephyr ignore -screen parameter if -resizeable is present
Summary: Xephyr ignore -screen parameter if -resizeable is present
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 11:01 UTC by GV
Modified: 2015-03-05 08:31 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.15.0-27.el7
Doc Type: Bug Fix
Doc Text:
Cause: Due to a bug in argument parsing, it was impossible to both ask Xephyr to make its window resizeable and specify its initial size. Consequence: Resizable Xephyr windows always created with size 100x100. Fix: Argument parsing code fixed. Result: Resizable Xephyr windows honor the requested initial size.
Clone Of:
Environment:
Last Closed: 2015-03-05 08:31:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0374 normal SHIPPED_LIVE xorg-x11, libdrm, and mesa bug fix and enhancement update 2015-03-05 12:52:35 UTC

Description GV 2014-08-09 11:01:05 UTC
Description of problem:
Xephyr ignore -screen parameter if -resizeable is present.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xephyr-1.15.0-7

Steps to Reproduce:
1. /usr/bin/Xephyr -screen 1280x1024+0+0 :2
Xephyr's window has size 1000x1000.

2. /usr/bin/Xephyr -screen 1290x1024+0+0 :2 -resizeable
Xephyr's window has size always 100x100 (no matter that argument to -screen is),

Comment 6 errata-xmlrpc 2015-03-05 08:31:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0374.html


Note You need to log in before you can comment on or make changes to this bug.