Bug 1128354 - wonky checkbox behaviour in the application addons section
Summary: wonky checkbox behaviour in the application addons section
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 11:03 UTC by Mat Booth
Modified: 2014-08-11 19:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 19:07:09 UTC


Attachments (Terms of Use)
screen cast of the wonky behaviour (163.34 KB, video/webm)
2014-08-09 11:03 UTC, Mat Booth
no flags Details

Description Mat Booth 2014-08-09 11:03:31 UTC
Created attachment 925365 [details]
screen cast of the wonky behaviour

If I uncheck an installed addon, but then change my mind and cancel in the confirmation dialog, then the checkbox still gets unchecked.

Then when I re-check the checkbox, I get a "Sorry, this did not work" -- presumably because the addon is already installed (I did not actually uninstall it)

I would expect it to not uncheck the checkbox until after I click ok in the confirmation dialog to indicate that I actually want the addon uninstalled.

See attached video (this might explain it better than the prose above).

$ rpm -q gnome-software
gnome-software-3.13.4-2.fc21.x86_64

Comment 1 Mat Booth 2014-08-09 20:32:49 UTC
I built gnome-software from upstream's master branch and the problem is still present there, too.

Comment 2 Kalev Lember 2014-08-11 19:07:09 UTC
Thanks for reporting this, Mat! Should be fixed by https://git.gnome.org/browse/gnome-software/commit/?id=5c8918900f000b9f29c2edcffdbe60edbec0c9e8


Note You need to log in before you can comment on or make changes to this bug.