Bug 1128358 - RFE: no way to replace package with a different one while dependencies stay untouched
Summary: RFE: no way to replace package with a different one while dependencies stay u...
Keywords:
Status: CLOSED DUPLICATE of bug 1110780
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 11:32 UTC by Honza Horak
Modified: 2014-08-11 10:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 10:59:06 UTC


Attachments (Terms of Use)

Description Honza Horak 2014-08-09 11:32:08 UTC
Description of problem:
Having two packages (foo, bar) doing pretty much the same thing and other package that depends on them; then when I want to switch the packages (i.e. uninstall foo package and install bar) I am not able to do that in one transaction in dnf. I can do it by first uninstalling foo in one transaction and then installing bar in the second transaction, which means dnf will remove all dependencies as well.

In yum there was `yum shell` command, that I could use to do more steps in one transaction and eventually replace foo with bar without loosing the dependencies.

I'm not saying we need `shell` command in dnf, but I'm missing the feature where I can replace a package without dependencies being touched.

If there is a way to do it with dnf, please, educate me. If not, take this as RFE. Actually implementing something like `yum shell` seems like a good way to do it.

Comment 1 Jan Zeleny 2014-08-11 10:59:06 UTC
Seems to be exactly what yum swap does, closing as duplicate. Feel free to reopen if I'm mistaken.

*** This bug has been marked as a duplicate of bug 1110780 ***


Note You need to log in before you can comment on or make changes to this bug.