Bug 1128361 - HA: Failure to start 'openstack-heat-api-cfn-clone' leads to HA deployment get paused at 60%.
Summary: HA: Failure to start 'openstack-heat-api-cfn-clone' leads to HA deployment g...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Installer
Assignee: Brad P. Crochet
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 13:56 UTC by Leonid Natapov
Modified: 2014-08-21 18:08 UTC (History)
8 users (show)

Fixed In Version: openstack-foreman-installer-2.0.20-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:08:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Leonid Natapov 2014-08-09 13:56:07 UTC
HA: Failure to start 'openstack-heat-api-cfn-clone' leads to  HA deployment get paused at 60%.  Need to "resume" in order to complete deployment.

HA controller deployment stopped at 60% complaining on puppet error.
The only error I can see in puppet log was the error bellow:
Deployment got stuck on 60%. After manually resuming the deployment it finished successfully.

change from notrun to 0 failed: /usr/sbin/pcs constraint order start openstack-heat-api-clone then start openstack-heat-api-cfn-clone returned 1 instead of one of [0]

/usr/sbin/pcs constraint order start openstack-heat-api-clone then start openstack-heat-api-cfn-clone returned 1 instead of one of [0]

Error: Resource 'openstack-heat-api-cfn-clone' does not exist

Comment 2 Brad P. Crochet 2014-08-13 18:04:33 UTC
PR submitted:

https://github.com/redhat-openstack/astapor/pull/352

Comment 3 Jason Guiditta 2014-08-13 19:54:59 UTC
Merged

Comment 6 Leonid Natapov 2014-08-18 09:10:59 UTC
Can't reproduce on openstack-foreman-installer-2.0.20-1.el6ost

Comment 7 errata-xmlrpc 2014-08-21 18:08:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.