Bug 1128368 - Numerous issues with Assignment editor for custom Service Task
Summary: Numerous issues with Assignment editor for custom Service Task
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Designer
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ER4
: 6.1.0
Assignee: Tihomir Surdilovic
QA Contact: Tomas Livora
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 15:19 UTC by Anton Giertli
Modified: 2015-12-10 10:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-10 10:43:43 UTC
Type: Enhancement


Attachments (Terms of Use)
[0] video from the designer (7.14 MB, video/ogg)
2014-08-09 15:19 UTC, Anton Giertli
no flags Details
[1] actual direction of the input mapping (50.48 KB, image/png)
2014-08-09 15:20 UTC, Anton Giertli
no flags Details
[2] expected direction of the input mapping (49.31 KB, image/png)
2014-08-09 15:20 UTC, Anton Giertli
no flags Details

Description Anton Giertli 2014-08-09 15:19:52 UTC
Created attachment 925368 [details]
[0] video from the designer

I am sorry for creating one bugzilla for multiple problems but it is all related to a single component - Assignment editor for custom Service Task (email, log, rest, ws, etc..)

1) Mapping is in the wrong direction for Data Inputs. We are mapping

FROM procVar TO taskInput (expected direction)
not
FROM taskInput TO procVar (actual direction)

Please see screenshots.

2) Data Output is not displayed in the Assignment section. Not sure what more to add here. 

This section of WID:
    "results" : [
        "Result" : new ObjectDataType(),
    ],

Is only displayed in the DataOutputSet for a custom service task, not in the assignemtn section.

3) DataInput/Output mapping must be configured in a specific sequence of steps otherwise it is not successful. You have to start by filling FROM field, then TO field. You can't do it otherwise. Please see attached video for more details - video actually points to all three problems.

If I should create separate bugs for these issues please let me know though I think it should be fixed all at once.

Comment 2 Anton Giertli 2014-08-09 15:20:20 UTC
Created attachment 925369 [details]
[1] actual direction of the input mapping

Comment 3 Anton Giertli 2014-08-09 15:20:51 UTC
Created attachment 925370 [details]
[2] expected direction of the input mapping

Comment 4 Anton Giertli 2014-08-09 15:24:47 UTC
it seems like I have simply forgotten "mapped to" keyword in the third case. However, some notification through UI that something went wrong would be nice.

Comment 5 Kris Verlaenen 2014-11-05 15:24:41 UTC
There have been several enhancements / fixes related to data assignments for 6.0.3 and 6.0.3 roll-up 1.  Could we retest what still needs to be fixed?  I would recommend opening individual issues for open issues, as that is much easier to keep track.

Some additional feedback:

1) Is as expected, as there are two ways you could specify a value, either by giving it an explicit value or by mapping a variable to it.  In most cases, the value is probably filled in, so by default the editor shows "data input" "is equal to" and the user can type a value in "To value".

2) Once a data output is defined, it should show in when creating a data output in the "From Object" dropdown.

3) I agree, an error message or something similar that some info (like "mapped to") is missing would be useful.

Note that https://bugzilla.redhat.com/show_bug.cgi?id=1152826 is still an open issue related to data assignments as well.

Comment 6 Anton Giertli 2014-11-19 20:26:00 UTC
Kris,

I'll keep the NEEDINFO flag and I will retest this with roll up patch applied and check which issue are still present.

Anton.

Comment 7 Tihomir Surdilovic 2014-11-27 20:18:47 UTC
fixed couple of issues with service tasks assignments on designer master. with these changes and the bigger changes to data assignments already in master this issue should be resolved now.

Comment 8 Sona Mala 2014-12-15 15:07:59 UTC
Tiho or Anton,
please can you tell me what is a result of this bugzilla? There was mention a lot of problems but ER3 does not contain any fix.

Problems:
1) it is not a bug. The current solution is expected. An user can assign a value. If he needs to map a value from a process variable then he has to rearrange the particular assignment. (Swap from and to object)

2) it is a real issue. This issue is not fixed by ER3. Predefined assignments should contains data inputs and data outputs together. (The assignment of "Result" is missing in ER3)

3) it is not a bug. The video sequence does not fill the type of the assignment.


There was the additional request (comment #4) for the error notification. Is it the part of this bz?


ER3 has similar behaviour as ER2. I assign this issue for 6.1.0 ER3 BPMS.

Please, close this issue if you open new issue for each problem.
In case that this bugzilla will be modified than specify what should be fixed.

Comment 9 Tihomir Surdilovic 2014-12-15 18:21:15 UTC
fix in designer 6.2.x branch

Comment 10 Tomas Livora 2015-02-09 17:25:50 UTC
This BZ is not fixed in BPMS 6.1.0 ER4.

1) I think what Anton tries to point out is that the current behavior is quite counterintuitive. When you use assignments to map the value from one object to another, the source is in 'From Object' column and the target in 'To Object' column. But when you want to directly assign a value to an object, according to Kris' comment 5, the object you work with is in 'From Object' column and the assigned value in 'To Value' column. It would be more intuitive if such object was in 'To Object' column and the value in 'From Value' column (renamed from 'To Value'). But it is only my (and probably Anton's opinion) and maybe there is some good reason why it is implemented the way Kris described in comment 5.

2) If the assignments section contains a template with input parameters necessary for the given service task, it should also contains output parameters (Result in case of REST or WS task).

3) This can also be fixed as Anton suggested in comment 4. But in version 6.1.0 when you want to add a new line in assignments panel, you have to choose if it is input assignment, input mapping or output mapping. So the 'Assignment Type' column no longer needs to be editable. I mean like 'To Object' column is not editable when you choose input assignment or 'To Value' column is not editable when you choose input mapping.

I seems that all these three issues are just suggestions for usability improvement and no functionality at all is broken. So I am lowering the severity of this BZ.

Comment 11 Kris Verlaenen 2015-02-09 18:47:46 UTC
Moving the suggested enhancements to next release for further improvements there.

Comment 12 Jeremy Lindop 2015-12-10 10:43:43 UTC
This BZ is no longer relevant in bpmsuite-6.2.0.GA


Note You need to log in before you can comment on or make changes to this bug.