Bug 112839 - Mishandling of firstboot/fsck case ditto kudzu/fsck
Mishandling of firstboot/fsck case ditto kudzu/fsck
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-03 13:00 EST by Alan Cox
Modified: 2014-03-16 22:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 23:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-01-03 13:00:30 EST
Description of problem:

Install FC1, wait for firstboot to appear then powercycle the box. (In
my case because it hung due to ACPI bugs).

The next graphical boot continues until the fsck question where it
flips to text mode, and then on. After "Adding Swap" it appears to
hang. In fact firstboot is now active on the X server but the scripts
have forgotten to flip back to tty8.

This is quite a nasty little bug because its not obvious why it hung
or how to fix it unless you are an expert.
Comment 1 Alan Cox 2004-10-15 12:07:03 EDT
Kudzu shows the same problem sequence. Both present on FC3t3
Comment 2 Bill Nottingham 2004-10-17 00:24:11 EDT
fsck will be fixed in 7.91-1. 

kudzu never calls chvt to switch to text mode; the only thing it does
is  pop up the 'details' screeen. What exactly are you seeing?
Comment 3 Alan Cox 2004-10-17 09:10:39 EDT
The second combination is fsck switches,  post fsck we hang for a
minute or so  which is in fact kudzu prompting the user on the
graphical display out of sight - if you fixed fsck you should have
fixed both cases I think.
Comment 4 Bill Nottingham 2004-10-17 15:37:46 EDT
OK, setting to modified.

Note You need to log in before you can comment on or make changes to this bug.