Bug 1128413 - engine cleanup fails due to Cleanup utility version mismatch
Summary: engine cleanup fails due to Cleanup utility version mismatch
Keywords:
Status: CLOSED DUPLICATE of bug 1118360
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 09:27 UTC by Ori Gofen
Modified: 2016-05-26 01:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-10 09:35:31 UTC
oVirt Team: ---


Attachments (Terms of Use)
log (103.95 KB, text/x-log)
2014-08-10 09:27 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-10 09:27:38 UTC
Created attachment 925473 [details]
log

Description of problem:
engine cleanup fails the messages on terminal:

[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-remove-20140810121951-1d82jq.log
          Version: otopi-1.3.0_master (otopi-1.3.0-0.0.master.20140728.git336a22e.el6)
[ ERROR ] Cleanup utility and installed version mismatch
          Please use a version of cleanup utility that matches the engine installed version (now engine-cleanup 3.5.0, engine 3.5.0_master)
[ ERROR ] Failed to execute stage 'Environment setup': Cleanup utility version mismatch
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-remove-20140810121951-1d82jq.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140810121952-cleanup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of cleanup failed
 


Version-Release number of selected component (if applicable):
rc1

How reproducible:
--

Steps to Reproduce:
1.engine-cleanup

Actual results:
operation fails due to version mismatch

Expected results:
operation should be successful 

Additional info:

Comment 1 Yedidyah Bar David 2014-08-10 09:35:31 UTC
Should be fixed at next RC.

*** This bug has been marked as a duplicate of bug 1118360 ***


Note You need to log in before you can comment on or make changes to this bug.