Bug 1128431 - Progress bar refresh problem, stuck at 60% controller, yet setup moved on to compute nodes
Summary: Progress bar refresh problem, stuck at 60% controller, yet setup moved on to ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-foreman-tasks
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Linux
low
unspecified
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 12:20 UTC by Tzach Shefi
Modified: 2015-04-28 16:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-28 16:20:07 UTC


Attachments (Terms of Use)
Progress bar auto refreashing failed (296.85 KB, image/jpeg)
2014-08-10 12:20 UTC, Tzach Shefi
no flags Details

Description Tzach Shefi 2014-08-10 12:20:17 UTC
Created attachment 925500 [details]
Progress bar auto refreashing failed

Description of problem: Setup Neutron none HA with two compute notes, over vm's, noticed deployment progress bar is stuck at 60% (controller) yet setup is actually still running passed Neutron controller now doing compute host OS deployment, looks like progress bar is stuck or failed to auto refresh. 

Moving to "Running steps" and back to "Task" progress bar not updated. Clicking on browser's refresh button fixed problem, progress bar now shows correct indication. 

See screen shot, on the right two compute hosts @ OS deployment stage, yet progress bar on right stuck at 60%. 


Version-Release number of selected component (if applicable):
rhel-osp-installer-0.1.9-1.el6ost.noarch
foreman-installer-1.5.0-0.6.RC2.el6ost.noarch
openstack-foreman-installer-2.0.18-1.el6ost.noarch


How reproducible:
Not sure

Steps to Reproduce:
1. Neutron none HA, two compute hosts
2. Start deployment check progress on hosts and bar
3.

Actual results:
Deployment is moving along as should, yet progress bar auto refresh stopped or failed.

Expected results:
Progress bar auto refresh should work.

Comment 3 Mike Burns 2014-08-11 12:30:53 UTC
Is there a chance that your session timed out?  If it does, the screen will stop updating.

Comment 4 Tzach Shefi 2014-08-13 11:34:20 UTC
Possible but unlikely, as I moved to "task" tab back and forth see initial posting, yet progress bar still didn't update. Nor was I asked to login again therefor guessing browsers didn't time out. Yet I could still be wrong. 

I'd say this is probably one of those fluke bugs, not sure what caused or how to recreate it, that's why I set it to low priority.

Comment 5 Arthur Berezin 2015-04-28 16:20:07 UTC
Refocusing engineering efforts on OSP7-Manager. 
Closing this BZ due to low priority and no customer cases attached.


Note You need to log in before you can comment on or make changes to this bug.