Bug 1128432 - Chronyd fails to start at boot with single NTP server configured
Summary: Chronyd fails to start at boot with single NTP server configured
Keywords:
Status: CLOSED DUPLICATE of bug 1124059
Alias: None
Product: Fedora
Classification: Fedora
Component: chrony
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 12:28 UTC by John
Modified: 2014-08-11 07:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 07:12:38 UTC


Attachments (Terms of Use)
text file containing relevant journal messages (3.30 KB, text/plain)
2014-08-10 12:28 UTC, John
no flags Details

Description John 2014-08-10 12:28:23 UTC
Created attachment 925501 [details]
text file containing relevant journal messages

Description of problem:
Chronyd service fails with "Could not connect NTP socket to 10.0.1.2:123 : Network is unreachable" message. The local server name configured in /etc/chrony.conf is being resolved to an IP addr (10.0.1.2 ) by the "dnsmasq" server located on the same box as the local "chrony" time server.

Chronyd can be successfully started via "systemctl restart chronyd" after boot is complete.


Version-Release number of selected component (if applicable):
fedora = 3.15.8-200.fc20.x86_64
chrony = chrony.x86_64   1.30-1.fc20


How reproducible:
always


Steps to Reproduce:
1.configure single local time server in /etc/chrony.conf
2./etc/chrony.conf entry = "server lname.ldomain iburst"
3.chronyd fails to start at boot

Actual results:
chronyd issues "Could not connect NTP socket to 10.0.1.2:123 : Network is unreachable" to journal.

Chronyd can be started after boot from commandline with "systemctl restart chronyd" 







Expected results:


Additional info:

Comment 1 Miroslav Lichvar 2014-08-11 07:12:38 UTC

*** This bug has been marked as a duplicate of bug 1124059 ***


Note You need to log in before you can comment on or make changes to this bug.