Bug 1128445 - [vdsm] - supervdsmServer _getPid required exception handling
Summary: [vdsm] - supervdsmServer _getPid required exception handling
Keywords:
Status: CLOSED DUPLICATE of bug 1128458
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.4.1-1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 13:58 UTC by Eldad Marciano
Modified: 2014-11-26 06:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 14:04:42 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Eldad Marciano 2014-08-10 13:58:01 UTC
Description of problem:
there is no exception handling for none pid vms.

/usr/share/vdsm/supervdsmServer

    def _getPid(self):
        pid = '0'
        try:
            vmName = self.conf['vmName'].encode('utf-8')
            pid = supervdsm.getProxy().getVmPid(vmName)
        except Exception:
            pass
        return pid


Version-Release number of selected component (if applicable):
vdsm-4.14.11-1.el6ev.x86_64

How reproducible:
many side affects

Steps to Reproduce:
1.
2.
3.

Actual results:
the process of the vm exist but no pid file.

Expected results:
shutdown vm in case no pid exist.

Additional info:

Comment 1 Eldad Marciano 2014-08-10 14:01:02 UTC
fix should be at this file /usr/share/vdsm/vm.py
not supervdsmServer

Comment 2 Michal Skrivanek 2014-08-11 14:04:42 UTC
will improve as part of bug 1128458

*** This bug has been marked as a duplicate of bug 1128458 ***


Note You need to log in before you can comment on or make changes to this bug.